Intel® Makers
Intel® Edison, Intel® Joule™, Intel® Curie™, Intel® Galileo
Announcements
Welcome - This is a Peer-to-Peer Forum only. Intel has discontinued these products but you may find support from other customers on this Forum
9880 Discussions

[Edison] IoTK activation issue

rfenj
Novice
1,457 Views

Hi,

I tried to use IoT Analytics but I am facing an Activation Issue. In the IoT analytics website, my device is active. But when I tried to register a component, my device is logging that it is not activated. please see below the command and log I got in the terminal.

Could you please tell how I can resolve this ?

0 Kudos
4 Replies
rfenj
Novice
190 Views

Hi,

Ideleted my device in the IoT dashboard and I re did the whole activation flow. After a new activation of the device I restart the Iotkit agent. But this is failing... So it may explain why I was not able to register a component previously.

Does anybody can help me to know why the iotkit-agent can not start properly ? Traces are not really very understandable to me.

Sergio_A_Intel
Employee
190 Views

Hi,

What version are you using, you can check your version with iotkit-admin –V.

You can also try to stop and start the agent with:

systemctl stop iotkit-agent

systemctl start iotkit-agent

Also what image are you using on your Edison, check the version with configure_edison –version.

Take a look at https://software.intel.com/en-us/intel-iot-platforms-getting-started-cloud-analytics Intel® IoT Platforms: Getting Started: Cloud Analytics | Intel® Developer Zone and follow the steps. Let us know what step you failed to complete.

Sergio

Carlos_M_Intel
Employee
190 Views

Hi redafenj

Have you been able to use your board with the Dashboard? Did you try with the suggestions above?

Regards,

Charlie

rfenj
Novice
190 Views

Hi

Thanks for your support, I just updated my iotkit version and rename my device and it is working fine.

Regards

 

Reda
Reply