Community
cancel
Showing results for 
Search instead for 
Did you mean: 
RElli7
New Contributor I
933 Views

Edison USB RNDIS Device - disable device to solve problems in windows 10

Hi Folks

The Problem

After I installed Edison I noticed significant "Slowdowns" in Windows 10. Most notably Browsers (Edge, IE and Google) and Outlook 2016.

  1. Web pages were not loading
  2. Web pages took a very long time to load (Upwards of 2 minutes)
  3. Outlook was looking for a profile for up to 3 minutes.

It took a while, but I finally identified the root of the problem to the "Intel Edison USB RNDIS Device";

  1. Under network connections this device shows up as a public network
    • I could not find a way to change this network to "Private"
    • I believe that the "public" designation kicks in "protection" from windows 10 and results in timeouts or something like it. (supposition on my part)
  2. If I disable the device the problem goes away!
    • I do not know the "unintended consequences" of disabling this device.
    • The console still works, for example, but I have not tested other things.

Hence, the workaround if you have this problem is to disable the device in Control Panel > Network and Internet > Network Connections

 

I would really like to know if there is a better way and if there are any consequences to this approach.

Thanks in advance I

2 Replies
Sergio_A_Intel
Employee
74 Views

Hi,

Thank you for providing a workaround. We will investigate if there's way to use the USB RNDIS Device without slowing down the performance.

We will pass this information to the appropriate team and contact you when we have an update.

Sergio

Sergio_A_Intel
Employee
74 Views

Hi,

After running some tests we concluded this is a known issue. Hopefully this will be fixed on future releases. Thank you for providing a workaround.

Sergio

Reply