Community
cancel
Showing results for 
Search instead for 
Did you mean: 
CChri35
New Contributor II
1,716 Views

Edison connected over USB blocks my windows host

Hi!

Since I'm using the Intel Edison board, I have the problem, that the when the Edison is connected over USB

and I use the Ethernet-Over-USB, my host PC (running Windows 8.1) hangs on specific actions. E.g. the

task doen't load, some program don't start when it's connected and start immediately right after pluggin

it of (pipe-like).

That's very annoyig and disturbs my workflow. Is there anything I can do against? Seems

that the Networking component blocks the Tools. When I connect over WLAN per SSH, there

is no problem.

Christoph

Tags (1)
22 Replies
Sergio_A_Intel
Employee
347 Views

Hi,

Specifically, what task is not loading, are you using any IDE? What tools get blocked when you connect the Edison? How are you powering the Edison? Does the Ethernet-Over-USB connection work intermittently or every time you connect it, it hangs your computer? What image are you using, what is the output of configure_edison –version?

Sergio

CChri35
New Contributor II
347 Views

Formerly I was using Eclipse, now I'm using Visual Studio. But the phenomenon is independent of the IDE. I'm using the USB-OTG Port, where

the power comes from. In the Moment, the Edison is up and the Flash-Storage is avaliable, the System is slowing down. E.g. I put the

Edison in, it comes up, then I start the Task manager. The window shows up, but shows only an empty frame. In the moment I plug the Edison

off, the content of the manager starts to populate.

 

configure_edison --version

146

Sergio_A_Intel
Employee
347 Views

This issue has not been reported on the later versions of the image. Try to flash your Edison to the latest image available using the Flash Tool Lite https://software.intel.com/en-us/articles/flash-tool-lite-user-manual IoT - Flash Tool Lite User Manual | Intel® Developer Zone . The latest image can be downloaded here http://downloadmirror.intel.com/25384/eng/edison-iotdk-image-280915.zip http://downloadmirror.intel.com/25384/eng/edison-iotdk-image-280915.zip .

Also, use an external power supply on J1 along with the Ethernet-Over-USB.

Let me know if the slowness on your computer persists after this.

Sergio

CChri35
New Contributor II
347 Views

That has nothing to do with the Image. As soon as the edison is connected over USB-OTG it slows down the host pc.

Sergio_A_Intel
Employee
347 Views

What is the name of the Ethernet to USB device, did you make any configuration to the Edison to make it work with the Ethernet Over USB device, if so, what changes? Do you have an internet connection through USB, how did you configure it? Does your PC hang as soon as you connect the Ethernet device?

Sergio

CChri35
New Contributor II
347 Views

The name is "Intel Edison USB RNDIS Device # 4". But that's nothing new, isn't it? Im meaning the Edison

Integrated Ethernet ove USB adapter. The Edison is fresh "out of the box" and the Host's PC Ethernet

adapter "Intel Edison USB RNDIS Device # 4" has the IP 192.168.2.20. The Host PC is connected to

internet with WLAN (Intel Centrino).

As soon as the Edison is reachable over SSH, the host slows down. E.g. when I click on "Network Center"

in Window 8.1, the window doesn't open but opens instantaneous after unpluggin the edison.

Sergio_A_Intel
Employee
347 Views

The host system, Windows in this case, is trying to use the Edison Ethernet over USB to access the internet and that slows things down. The easy solution is to disable "Intel Edison USB RNDIS Device # 4", connect Edison Wi-Fi to the network and access Edison through the Wi-Fi.

Sergio

CChri35
New Contributor II
347 Views

I'm forced to use USB / Ethernet. How I can I prevent windows from using the Edison as Internet source.

Sergio_A_Intel
Employee
347 Views

We're working to try and reproduce your issue. Did you make any additional changes to the image to make the Ethernet-Over-USB adapter work with your Edison? Did you install any additional drivers, if so, which ones and how. How did you configure the Ethernet-Over-USB device?

Sergio

Sergio_A_Intel
Employee
347 Views

Have you had a chance to continue to work with the Ethernet-Over-USB adapter? Please provide the information requested on the previous reply.

Sergio

CChri35
New Contributor II
347 Views

No. I didn't make any changes. I'm using the original Image of Intel. I CAN work with the Edison.

But every internet-dependent task runs very very slow. I have to wait minutes sometimes.

This is ultra annoying. And I'm wondering nobody else has this behaviour. In the meantime I changed

to window 10 and the problem is there also. How can i tell windows not to search for a internet

connection throught the Edison ethernet adapter? Wifi using only is no option.

Sergio_A_Intel
Employee
347 Views

Under Network connections right click on the RNDIS device and select properties. In the first tab scroll down and uncheck IPV4 and IPV6.

Try this and let me know your results.

Sergio

CChri35
New Contributor II
347 Views

But this - as I expected - blocks any connection to the Edison device. So am I the only one with that problem?

This is such annnoying...

CChri35
New Contributor II
347 Views

So is there anything new?Any workaround for Windows 10??

Working with it keeps me waiting for hours...

Am I really the only one with this problem?

CChri35
New Contributor II
347 Views

CAN YOU PLEASE SOLVE THIS???

This drives me crazy. I'm always waiting. You're supporting Windows -> FIX THIS!!!!!!!!!

Sergio_A_Intel
Employee
347 Views

Hi Christoph.P,

We want to let you know we'll do our best to help you with this situation. Since we last provided a suggestion, there has been newer image versions released. Could you please try to refresh your Edison to the newest version? It can be downloaded here https://software.intel.com/en-us/iot/hardware/edison/downloads https://software.intel.com/en-us/iot/hardware/edison/downloads.

Let us know if you continue to see the same issue after re-flashing. We'll be waiting for your response.

-Sergio

CChri35
New Contributor II
347 Views

20160606 -> Problem remains...

As somebody said the problem seems, that windows tries to get an internet connection from the edisonsethernet adapter and therefore is slow and fails with some requests (who use internet). As soon as the

adapter is connected to th PC and it is pingable the problem is there.

So I think solution is to say windows "ignore the edison's ethernet adapter" for your internet attempts. But

all I tried (including change the metric values), dind't led me to the solution...

idata
Community Manager
347 Views

We'll look into this and post a suggestion as soon as possible.

 

 

-Sergio

 

idata
Community Manager
347 Views

Hi Christoph,

 

 

We are wondering if you're seeing this issue on multiple networks, is this the case? We have seen this behavior on our work computer/network but not on a personal computer/network. Have you tried changing the connection preferences on your computer? Please take a look at the following guide http://www.howtogeek.com/117083/how-to-make-your-laptop-choose-a-wired-connection-instead-of-wireles... http://www.howtogeek.com/117083/how-to-make-your-laptop-choose-a-wired-connection-instead-of-wireles....

 

It is possible that the network configurations does not allow multiple connections on a client.

 

 

When connecting the Edison to your computer, can you see your network IP on your Wire/wireless connection along with 192.168.2.* for the Edison device?

 

 

Regards,

 

-Pablo
RRatc
Beginner
100 Views

I'm seeing the same problem using Ethernet over USB. Any program that wants to connects to the Internet or to local server hangs until there is a timeout if I have the Edison plugged in. As soon as I remove the USB cable, the program immediately continues. I have to disconnect the USB connection, start the application (like NetBeans), and then reconnect the USB afterwards. I'm using the this image from Reach https://files.emlid.com/images/ReachImage_v2.1_beta.zip https://files.emlid.com/images/ReachImage_v2.1_beta.zip .

Reply