Intel® Makers
Intel® Edison, Intel® Joule™, Intel® Curie™, Intel® Galileo
Welcome - This is a Peer-to-Peer Forum only. Intel has discontinued these products but you may find support from other customers on this Forum
9877 Discussions

Edison not mounting, not flashable, serial works


I've been trying to figure out how to get along with the Edison for about a day now. I'm using a Mac with the Arduino Breakout and it just won't cooperate very well. My end goal is the flash the Yocto image with the meta-oic layer (IoTivity) from here: Options for installing IoTivity stack on Edison · intelmakers/GETTING-STARTED Wiki · GitHub

Yesterday I had problems with accessing the Serial interface so I replugged it a bunch of times and reflashed it using the script (latest "normal" image, no meta-oic). This made the serial interface work so I went ahead and copied the files over to the flash drive and ran the "reboot ota" command. This did nothing since the configuration of the edison was still there afterwords (wifi, name, password...). I tried to run the script from the IoTivity yocto image but that didn't work. Now, I can't mount the board anymore, it doesn't show up as a drive on my Mac or another Ubuntu computer I tried. I tried to flash it with the "normal" yocto image again but now the script fails. What is going on? I'm having so much problems with just the basics of connecting it to my computer.


The flashall scripts now outputs: (when it says plug and reboot I disconnect both cables and reconnect them, no power supply so it kills power doing so)

Using U-Boot target: edison-blankcdc

Now waiting for dfu device 8087:0a99

Please plug and reboot the board

Timed out while waiting for dfu device 8087:0a99

DEBUG: lsusb

./ line 74: lsusb: command not found

DEBUG: dfu-util -l

dfu-util 0.9

Copyright 2005-2009 Weston Schmidt, Harald Welte and OpenMoko Inc.

Copyright 2010-2016 Tormod Volden and Stefan Schmidt

This program is Free Software and has ABSOLUTELY NO WARRANTY

Please report bugs to

Deducing device DFU version from functional descriptor length

Found Runtime: [05ac:828f] ver=0118, devnum=5, cfg=1, intf=3, path="20-3.3", alt=0, name="UNKNOWN", serial="UNKNOWN"

Did you plug and reboot your board?

If yes, please try a recovery by calling this script with the --recovery option



Am I missing something here? I usually plug both USB cables into my computer and that gives me a serial interface and no mount. Yesterday the same configuration meant that it mounted and no serial. Also, "ls /dev/tty.* " used to list tty.usbmodem-1413 before when I could mount but now it lists /dev/tty.usbserial-A903UMWH. I could not connect to tty.usbmodem-1413 with screen but it works with tty.usbserial-A903UMWH. Basically I have had access to the mounted volume OR serial connection but never both at the same time since I got this board.

2 Replies
Community Manager




So running the flashall script and doing reboot ota made the board unmountable? The reboot ota method is not recommended anymore. You can see an explanation why here /docs/DOC-98643 . The recommended method is the Flash Tool Lite.



I'd suggest you to try the flash tool lite, also described in the document posted above.



Let us know your results.







I could mount it again after rebooting the computer . I had restarted it several times before with the board disconnected (no usbs connected and no poer supply to the edison) and then tried to connect it with no sucess (two usb cables, no power supply). This time I left both cables in with a power supply so it was on while my Mac was rebooting. It just magically worked. I'm very confused by this, is there some driver trouble with Macs. I don't dare to reboot it again because that might break it again.

After flashing it appears that the the build was old with yocto 1.6.2 and iotivity 0.9 so maybe that is why it works. I have compiled my own yocto now with iotivity 1.0.1 and latest yocto.