Intel® Makers
Intel® Edison, Intel® Joule™, Intel® Curie™, Intel® Galileo
Announcements
Welcome - This is a Peer-to-Peer Forum only. Intel has discontinued these products but you may find support from other customers on this Forum
9872 Discussions

Edison not powering on

John_G_Intel
Employee
958 Views

Hi all,

I've been using an Edison breakout board for many projects over the past few months and had zero problems with it.

Until Friday.

On Friday, I was putting the Edison into my Roomba so I could start scooting around. When I plugged the Edison in, I noticed that DS3 stayed on longer than usual. Then I saw that DS1 and DS2 were blinking quickly in unison. I left it unplugged over the weekend to see if it would sort itself out. Came back today, same thing is happening. The serial port seems to connect, but I see no output in PuTTY. I'm unable to reflash the board, as the EMMC doesn't show up when plugged into my computer. I've reseated the SoC and used different power sources (2 different USB cables and 2 different power supplies). Same thing happens every time.

I have not tampered with the hardware of the breakout board. I typically use USB devices and python scripts for my projects.

Any idea what could be causing this behavior? Is it more likely the SoC or the board?

3 Replies
John_G_Intel
Employee
128 Views

Well, I think I figured it out.

After having it plugged in for a while, I noticed a strange smell.

And a bright orange spot on U39.

So I'm going to get a new kit and see if that fixes it. If not, I'll be back!

Pablo_M_Intel
Employee
128 Views

Hi ValourUnbound,

This seems to be a warranty case, could you please open a ticket in here https://customercare.intel.com/?lang=en-US https://customercare.intel.com/?lang=en-US, so we can continue helping you? We will continue the troubleshooting process in there.

Regards,

Pablo

John_G_Intel
Employee
128 Views
Reply