Community
cancel
Showing results for 
Search instead for 
Did you mean: 
KZama2
Novice
1,374 Views

Edison time does not sync with PC time

Hi all!

 

I followed every instructions given to setup my Intel Edison, but when i choose "Sync PC time w/clock on target device" at "Manage your daemon/IoT device" button in Intel XDK 2571,

 

the date appear to be correct but the time is lagging hours back. Any idea?

Additional info:

Dell studio 1555 - window 7 Ultimate - 32-bit

(UTC+08:00) Kuala Lumpur, Singapore.

Thx in advance!

0 Kudos
4 Replies
Matthias_H_Intel
Employee
113 Views

it's pretty much in sync - just the timezone isn't synced but given in UTC

Sergio_A_Intel
Employee
113 Views

Hi,

This may be useful as well http://www.thegeekstuff.com/2010/09/change-timezone-in-linux/ How To: 2 Methods To Change TimeZone in Linux

Sergio

Matthias_H_Intel
Employee
113 Views

Intel_Alvarado wrote:

Hi,

This may be useful as well http://www.thegeekstuff.com/2010/09/change-timezone-in-linux/ How To: 2 Methods To Change TimeZone in Linux

Sergio

although you can set "manually" as described in the link I'd rather recommend using

# timedatectl -h

timedatectl [OPTIONS...] COMMAND ...

Query or change system time and date settings.

-h --help Show this help message

--version Show package version

--no-pager Do not pipe output into a pager

--no-ask-password Do not prompt for password

-H --host=[USER@]HOST Operate on remote host

-M --machine=CONTAINER Operate on local container

--adjust-system-clock Adjust system clock when changing local RTC mode

Commands:

status Show current time settings

set-time TIME Set system time

set-timezone ZONE Set system time zone

list-timezones Show known time zones

set-local-rtc BOOL Control whether RTC is in local time

set-ntp BOOL Control whether NTP is enabled

KZama2
Novice
113 Views

Hi all!

thanks alot for the reply guys! it really helps me figure out how to solve the issue i encountered.

I tried to get hold of UTC file with UTC+0800 but unfortunately rest me unsettle.

 

so what i did is ls into zoneinfo file and look for suitable time zone which turn out to be in Etc/GMT-8.

 

and now its working!

 

 

Reply