Community
cancel
Showing results for 
Search instead for 
Did you mean: 
YYan8
New Contributor I
1,402 Views

Error 15: File not found; problem with booting on a SD card for Galileo Gen 2

Jump to solution

Hi, guys,

I am building a default image for Galileo Gen 2 without any changes, exactly following the steps in the building guide, release 1.2.1.1, which I think is the newest one.

I am building a full-featured Linux for SD card, so following the Section 6 of the guide. I don't build grub and anything else, just in meta-clanton_v1.2.1.1.

After building and following the instruction, I copy the required files into a SD card. I followed the link: https://software.intel.com/en-us/get-started-galileo-linux-step1 IoT - Step 1: Make a bootable micro SD card | Intel® Software to format the SD card, so it won't be a problem.

Then I got Error 15: File not found after booting, like the image below:

At first, I build it on a Linux Mint 17.1, then I tryied Ubuntu 14.04. They all failed.

How to solve this problem?

Thanks.


Accepted Solutions
YYan8
New Contributor I
82 Views

Finally, thanks to a developer, the problem is due to grub configuration file.

grub.conf is misconfigured so that it can not load the kernel.

root=/dev/**** is not correct, then change it to the right interface according the command "lsblk", then the problem is solved.

Thanks for all your help.

View solution in original post

10 Replies
Padraig_C_Intel
Employee
82 Views

Hi AU_yzy0050,

If possible I would suggest using Debian version 7 as a host for building the image, as this release has been tested on this distro. I have tried to build the image on other distros such as fedora and have encountered problems similar to yours above.

YYan8
New Contributor I
82 Views

Thank you, Padraigc, I will try Debian 7.

Padraig_C_Intel
Employee
82 Views

No problem, if you encounter any more problems, please post on here again

idata
Community Manager
82 Views

Hello AU_yzy0050,

 

 

If you build the Yocto image basing it on Quark's BSP 1.2.1.1 ( https://downloadcenter.intel.com/download/23197/Intel-Quark-SoC-X1000-Board-Support-Package-BSP-) you don't need follow the steps in https://software.intel.com/en-us/get-started-galileo-linux-step1 as those steps are only required to boot on the eglibc image. You can simply copy the files into the SD card and it should be able to boot.

 

 

However, you will have to make sure to rename the image files correctly.

 

 

-Peter.
YYan8
New Contributor I
82 Views

Yes, I did exactly as what the guide said. The error just appeared.

I think no matter Mint or Ubuntu should work. Anyway, I will try Debian 7 for sure.

Thanks.

Will let you know if the problem is solved.

YYan8
New Contributor I
82 Views

Please check this thread.

The guy also had the same problem, but after switching to Debian 7, the problem was gone.

Now, Debian 7 is updated to 7.11. I don't if this version will work.

Padraig_C_Intel
Employee
82 Views

Hi AU_yzy0050,

I can confirm it works on Debian 7.11, that is what I am using at the moment.

YYan8
New Contributor I
82 Views

Hi, Padraigc,

I just tried Debian 7.11, but I still got the problem...

What could be the possible reason for this issue? I'm frustrated now.

Before starting building, I got this error, like the thread:

ERROR: OE-core's config sanity checker detected a potential misconfiguration.

Either fix the cause of this error or at your own risk disable the checker (see sanity.conf).

Following is the list of potential problems / advisories:

TMPDIR is setgid, please don't build in a setgid directoryTMPDIR is setuid, please don't build in a setuid directory

Then I installed all suggested packages, still got the error. Then I created the file by touch conf/sanity.conf as suggested.

Could this error be the reason?

Thank you.

Padraig_C_Intel
Employee
82 Views

Hi AU_yzy0050,

Could you please check the permissions attached to your whole build directory (i.e. meta-clanton_v1...) by typing: "ls -l" in the directory above meta-clanton_v1.

I've a feeling this is a permissions issue due to this: https://www.mail-archive.com/openembedded-core@lists.openembedded.org/msg54490.html https://www.mail-archive.com/openembedded-core@lists.openembedded.org/msg54490.html

YYan8
New Contributor I
83 Views

Finally, thanks to a developer, the problem is due to grub configuration file.

grub.conf is misconfigured so that it can not load the kernel.

root=/dev/**** is not correct, then change it to the right interface according the command "lsblk", then the problem is solved.

Thanks for all your help.

View solution in original post