Intel® Makers
Intel® Edison, Intel® Joule™, Intel® Curie™, Intel® Galileo
Welcome - This is a Peer-to-Peer Forum only. Intel has discontinued these products but you may find support from other customers on this Forum
9873 Discussions

Error: Connect ETIMEDOUT is really hindering my progress

New Contributor I

Please help me, Intel XDK IOT brings up the error above and the "ENUNTREACH" error at other times. I'm being able to establish connection through the serial terminal, but there i can only write linux codes in the console, can't run main.js codes, when i tried running the main.js it replied: "Please connect to an IOT device" as shown in the below image. This is really keeping me back and I'm working on a school project. Please I need assistance on what to do.

3 Replies


Are you booting from the SD with the Yocto image? Do you ever receive a confirmation display that says you are connected? I can see in the first image that you've not selected a device. Do you see your Galileo in the Select a Device list. If not connect manually using these steps:

  1. From the IoT Device drop-down list, select Add Manual Connection.
  2. In the dialog box that opens, provide the connection information for your development board, as follows:

Type the IP address in the Address field.

Type the port number in the Port field. The default is 58888.

3.Type your user name and password in the User Name and Password fields.

4.Click Connect. A confirmation message is displayed.


New Contributor I

I went through all of those steps listed and when i click connect, it gives me that error message in the image.

Did i pick the wrong address as IP address? I got it from the console after typing the "ifconfig" linux command=> " inet addr:"

New Contributor I

I say thanks to all who tried to help.

I finally got it working. I discovered I was getting those errors because the galileo board and the PC running the intel XDK IOT were not on the same LAN, as soon as I did this, I did'nt get those errors any more.