Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
New Contributor I
1,187 Views

Example Error "Iotkit"

Jump to solution

Example Error Iotkit

Error Message :

Arduino: 1.6.7 (Windows 10), Board: "Intel® Edison"

Unable to find C:\Users\DELL\Documents\Arduino\libraries\IoTkit\examples\IoTKitActuationExample\IoTKitActuationExam... in C:\Users\DELL\Documents\Arduino\libraries\IoTkit\examples\IoTKitActuationExample

Error compiling.

This report would have more information with

"Show verbose output during compilation"

enabled in File > Preferences.


Accepted Solutions
Highlighted
New Contributor I
18 Views

I have tried many methods. I found the solution. I deleted new Arduino release. Now it is running smoothly.

View solution in original post

10 Replies
Highlighted
Employee
18 Views

Hi mekatronik,

Did you check the location C:\Users\DELL\Documents\Arduino\libraries\IoTkit\examples\IoTKitActuationExample?

I'm guessing that you are including a third party library, is this right? If you are doing this, which steps did you follow and could you post a link to the place from where you are downloading it?

Regards,

Charlie

Highlighted
New Contributor I
18 Views

Yes I checked.

I downloaded from here

https://github.com/enableiot/iotkit-samples/tree/master/arduino iotkit-samples/arduino at master · enableiot/iotkit-samples · GitHub

0 Kudos
Highlighted
Employee
18 Views

Hi mekatronik,

The https://github.com/enableiot/iotkit-samples/tree/master/arduino/IoTkit IoTkit folder must be placed in the following location:

C:\Users\You\AppData\Local\Arduino15\packages\Intel\hardware\i686\1.6.2+1.0\libraries\

Once you have the IoTkit folder in there you should be able to use the library, if you have the folder there and still have problems while compiling the code, go to C:\Users\You\Documents\Arduino\libraries and delete the folder and content of \IoTkit

Let me know if this works for you.

Regards,

Charlie

0 Kudos
Highlighted
Employee
18 Views

Hi mekatronik,

I would like to know if you are adding the library as I mentioned in the post above or if you are doing this in a different way.

Kind regards,

Charlie

0 Kudos
Highlighted
New Contributor I
19 Views

I have tried many methods. I found the solution. I deleted new Arduino release. Now it is running smoothly.

View solution in original post

Highlighted
New Contributor I
18 Views

Hi again

I get iot kit error again. I have reinstalled the Windows system. reinstalled drivers and arduino. But not working arduino iot kit. Help me please

0 Kudos
Highlighted
Employee
18 Views

Hi mekatronik,

Are you having the same error message? If there is a different one, please post it here.

Did you delete the folder ..\Documents\Arduino\libraries\IoTkit?

Where are you placing the files for the library and which Arduino IDE version are you using?

Regards,

Charlie

0 Kudos
Highlighted
New Contributor I
18 Views

I deleted but I get error

Error message:

Arduino:1.6.5 (Windows 8.1), Kart:"Intel® Edison"

i586-poky-linux-g++: error: C:\Users\DELL\AppData\Local\Temp\build5228842203334704066.tmp/core.a: No such file or directory

Multiple libraries were found for "Ethernet.h"

Used: C:\Users\DELL\AppData\Roaming\Arduino15\packages\Intel\hardware\i686\1.6.7+1.0\libraries\Ethernet

Not used: C:\Intel\arduino-1.6.5\libraries\Ethernet

0 Kudos
Highlighted
Employee
18 Views

Hi mekatronik,

I suggest you to install the https://www.arduino.cc/en/Main/Software latest Arduino IDE, V1.6.8. I know you downgrade the version you were using from 1.6.7 to 1.6.5. But you can try with the latest one.

One thing you can do is adding a copy of Ethernet.h and Ethernet.cpp in the IoTkit folder. If the problem is a conflict between the name of the libraries you can:

1. Change the name of the library

2. Delete the Ethernet library located in C:\Intel\arduino-1.6.5\libraries\Ethernet. In case you will not use this one.

Regards,

Charlie

0 Kudos
Highlighted
New Contributor I
18 Views

I installed Arduino 1.6.8. it's working anymore. Thank you

0 Kudos