Intel® Makers
Intel® Edison, Intel® Joule™, Intel® Curie™, Intel® Galileo
Welcome - This is a Peer-to-Peer Forum only. Intel has discontinued these products but you may find support from other customers on this Forum
9872 Discussions

Failing to upgrade edison firmware - and other issues .. can someone help.

New Contributor I

I have a brand new Edison Arduino board and I keep running into problems.

The guided set up process failed during flashing. No explanation

  • I tried DFU-util/flashall.bat to update the firmware. I can start the process but it aborts (Device has DFU interface, but has no DFU functional descriptor).
  • I was unable to establish a serial connection with the device with putty
  • However I can create an SSH IP connection over the USB link and access the linux shell.
  • From there I can set up the wifi and then establish an SSH link over wifi.
  • I tried to use the configure_edison shell tool to upgrade from the linux shell and this the dialog with Mr Edison.

root@edison:~# configure_edison –version


root@edison:~# configure_edison --latest-version


root@edison:~# configure_edison –upgrade

Could not upgrade device firmware. Quitting.

invalid literal for int() with base 10: '159.devkit

Am I correct to assume the firmware is a development version and is not upgradeable.

  • Also, I was able to compile a sketch with the Arduino IDE and upload it once. Further attempts failed during the loading.
  • On my PC, I do see the two come ports and all seems fine.
  • I am able to

.. any idea, it seems like a lot of different issues ...

2 Replies

Hello CABrouwers,

The 159.devkit image is the latest image available in Intel® Edison Downloads. The 146 image is the latest image that can be installed from the configure_edsion method, this is because the 159 and 159.devkit images are too big for the partitions in 146 so they can be only be flashed manually.

Since you are having issues with the method, then I'd suggest you to flash your board with Flash Tool Lite. You can find the tool and a guide on how to use it in Intel® Edison Downloads.

If you can see the two COM ports but you can't start a serial connection to the Edison, then it might be related to the board's drivers. Have you installed the board's FTDI driver? In case you haven't, you can find it in D2XX Direct Drivers.


New Contributor I


Thanks for your reply. I am reassured that I have the right image and that the configure_edison update failure is to be expected.

With regard to using Flash Tool Lite . I tested and tried many things to no avail. I removed and reinstalled the FTDI driver. Everything checks out apparently but Flash Tool Lite still fails and I am unable to establish a serial link with Putty (even though I am able to open a port).


Anyway, I was able to program the Edison with both the Intel XDK and Eclipse through a wifi connection. That also allowed me to test the UART and it is working, It is all I need so I will stick to this method and not worry about the other issues.