Community
cancel
Showing results for 
Search instead for 
Did you mean: 
CJeng
Novice
1,462 Views

Ffmpeg error - symbol lookup error: /usr/lib/libnss_mdns.so.2: undefined symbol: pthread_mutex_lock

Jump to solution

I use Yocto 3.0, the webcam is logitech c270 with an external power supply, I install ffmpeg follow https://github.com/drejkim/edi-cam/blob/master/bin/install_ffmpeg.sh https://github.com/drejkim/edi-cam/blob/master/bin/install_ffmpeg.sh

When I run ffmpegffmpeg

root@edison:~# /home/root/bin/ffmpeg/ffmpeg -s 640x480 -f video4linux2 -i /dev/video0 -f mpeg1video -b:v 800k -r 30 http://127.0.0.1:8082/password/ http://127.0.0.1:8082/password/

I got an error

ffmpeg version 3.0.1-static http://johnvansickle.com/ffmpeg/ http://johnvansickle.com/ffmpeg/ Copyright (c) 2000-2016 the FFmpeg developers

built with gcc 5.3.1 (Debian 5.3.1-13) 20160323

configuration: --enable-gpl --enable-version3 --enable-static --disable-debug --enable-libmp3lame --enable-libx264 --enable-libx265 --enable-libwebp --enable-libspeex --enable-libvorbis --enable-libvpx --enable-libfreetype --enable-fontconfig --enable-libxvid --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libtheora --enable-libvo-amrwbenc --enable-gray --enable-libopenjpeg --enable-libopus --enable-libass --enable-gnutls --enable-libvidstab --enable-libsoxr --enable-frei0r --enable-libfribidi --disable-indev=sndio --disable-outdev=sndio --enable-librtmp --enable-libmfx --enable-libzimg --cc=gcc

libavutil 55. 17.103 / 55. 17.103

libavcodec 57. 24.102 / 57. 24.102

libavformat 57. 25.100 / 57. 25.100

libavdevice 57. 0.101 / 57. 0.101

libavfilter 6. 31.100 / 6. 31.100

libswscale 4. 0.100 / 4. 0.100

libswresample 2. 0.101 / 2. 0.101

libpostproc 54. 0.100 / 54. 0.100

Input # 0, video4linux2,v4l2, from '/dev/video0':

Duration: N/A, start: 6781.808508, bitrate: 147456 kb/s

Stream # 0:0: Video: rawvideo (YUY2 / 0x32595559), yuyv422, 640x480, 147456 kb/s, 30 fps, 30 tbr, 1000k tbn, 1000k tbc

ffmpeg: symbol lookup error: /usr/lib/libnss_mdns.so.2: undefined symbol: pthread_mutex_lock

And I can run at my pc without error.

1 Solution
CJeng
Novice
169 Views

It's my fault, the output target I set is a domain name, I don't know why ffmpeg can't connect directly. I change the domain name to IP address, it works.

View solution in original post

1 Reply
CJeng
Novice
170 Views

It's my fault, the output target I set is a domain name, I don't know why ffmpeg can't connect directly. I change the domain name to IP address, it works.

View solution in original post

Reply