Community
cancel
Showing results for 
Search instead for 
Did you mean: 
LCorn3
Novice
1,160 Views

First time user... some observations that may help others?

So I'm a first time Edison user, going for the entire experience. Remember you can only be a virgin once. (Note: I'm running Windows 10 Operating System)

I followed along with the Intel install guide:

https://software.intel.com/en-us/articles/assemble-intel-edison-on-the-arduino-board https://software.intel.com/en-us/articles/assemble-intel-edison-on-the-arduino-board

https://software.intel.com/en-us/get-started-edison-windows-step2 https://software.intel.com/en-us/get-started-edison-windows-step2 (Run the installer, find com ports)

https://software.intel.com/en-us/get-started-edison-windows-step3 https://software.intel.com/en-us/get-started-edison-windows-step3 (Setup Putty, connect to com port)

https://software.intel.com/en-us/get-started-edison-windows-step4 https://software.intel.com/en-us/get-started-edison-windows-step4 (Connect to WIFI)

https://software.intel.com/en-us/get-started-edison-windows-step5 https://software.intel.com/en-us/get-started-edison-windows-step5 (Connect to IDE)

https://software.intel.com/en-us/node/590582 https://software.intel.com/en-us/node/590582 (Troubleshooting)

A few random observations.

  • I was able to connect via Putty right away.
  • I was able to connect to WIFI. Awesome. Initially I did NOT change name or password (more on this later...)
  • I was able to get the Arduino Integrated Development Environment (IDE) up and running with blink pretty easily. I didn't need to login to use the Arduino IDE tool.
  • Initially, I was not able to figure out the whole Intel XDK IoT (Internet of Things) edition IDE. I simply was not able to login. So, here's my first goof up. Apparently when you do the Serial/Putty connect you get a chance to setup and change name and change password. So I wasted too much time there.

Simple hint: Name = Device Display Name, NOT LOGIN NAME. Not sure how I missed that.

Display name = thomas

login name = root

password = (......)

  • Once I got that figured out I was easily able to use the node.js stuff within the XDK IoT IDE.
  • Onward to C/C++ .. I initially saw an article telling me that I could use Microsoft Visual Studio to create C/C++ files for the Edison. Yes that's true, you just have to plop down a bunch of $$ and buy a license for visualgdb.com compiler library which will compile your code with the GNU compiler system, so the code runs in Yocto Linux. Ugh. So, I'm like, okay, I'll try the Eclipse download. I tried to do the download via the Intel Edison package links, but got a total fail there. The error code states: "Eclipse: Integrity checking failed, Source file is incorrect. iotdk-ide-win.7z" Not sure what was up with that. I'll try do to a complete Eclipse download from the Oracle site later. Stay tuned.
  • Other stuff: I was easily to File Transfer Protocol (FTP) to the Edison unit via secure SFTP

So, I did watch these awesome videos from the Intel Garage.. Kind of quirky, but fun to watch. It was seeing these videos a few weeks ago that gave me the push in the direction of the Edison kit.

Image and video processing with Intel Edison

http://www.intel.com/content/www/us/en/do-it-yourself/garage-content/garage-facial-recognition-video... http://www.intel.com/content/www/us/en/do-it-yourself/garage-content/garage-facial-recognition-video...

http://www.intel.com/content/www/us/en/do-it-yourself/garage-content/garage-webcam-hook-up-video.htm... http://www.intel.com/content/www/us/en/do-it-yourself/garage-content/garage-webcam-hook-up-video.htm...

http://www.intel.com/content/www/us/en/do-it-yourself/garage-content/garage-streaming-web-video.html http://www.intel.com/content/www/us/en/do-it-yourself/garage-content/garage-streaming-web-video.html

http://www.intel.com/content/www/us/en/do-it-yourself/garage-content/garage-audio-voice-recognition-... http://www.intel.com/content/www/us/en/do-it-yourself/garage-content/garage-audio-voice-recognition-...

So, I'm trying to reproduce the Edison code from within those examples. I'm not a Python guy, but the samples should be simple enough. And here's where I hit a hard wall. There is a sample where you hook up a video camera, create an image file. To see the file, you have to copy it over to the website public facing directory. I've done that per the instructions (the actual directory is: `/usr/lib/edison_config_tools/public/ ` ) Note: there was a typing error here.. the code on the intel website was usr/lib/ldison ... I can see the files there, including index.html, 404.html, logo-intel.png, main.css, exit.html... it looks like a regular web repository directory. Unfortunately I can't point my browser to any of those files contained there. If the browser isn't pointing to the root, then you get an error mesage in the form: `The page at /blah.png was not found. `

Not sure what I'm doing wrong. I can see the server code (node.js file "edison-config-server.js" which uses http module to serve up files. I don't understand why the files contained within the /usr/lib/edison_config_tools/public/ aren't visible. I suspect there is a problem inside the file edison-config-server.js, but I'm not seeing it at first glance. What I do know is http://thomas.local/ http://thomas.local works fine to display index.html with main.css and logo-intel.png, but no go on http://thomas.local/blah.png http://thomas.local/blah.png (my video capture snapshot) or http://thomas.local/exit.html http://thomas.local/exit.html (or any of the other five or six html files that are stored in usr/lib/edison_config_tools...

4 Replies
Sergio_A_Intel
Employee
54 Views

Hi,

Are you sure you are running the latest image? The instructions on the video are not the full steps to get the final result of getting a picture in the Device Information page. The detailed steps can be found here http://www.intel.com/content/www/us/en/do-it-yourself/garage-content/garage-facial-recognition-instr... Maker Garage Facial Recognition with Intel® Edison Guide and the Python code here https://raw.githubusercontent.com/SCUMakerlab/Intel-Edison-Code/master/FacialRecognition.py https://raw.githubusercontent.com/SCUMakerlab/Intel-Edison-Code/master/FacialRecognition.py . You also say that the contents in /usr/lib/edison_config_tools/public/ aren't visible; can you see the contents from the Linux terminal using cat /usr/lib/edison_config_tools/public/ ?

Sergio

LCorn3
Novice
54 Views

Sergio,

Thanks for your reply. I'm well aware of the git stuff and the pdf instructions for each of the four links I've provided in my original posting. So what's not clear is whats going on at the directory /usr/lib/edison_config_tools/public... when I check the code at index.html, its quite a large file, certainly not what i see at http://thomas.local/ http://thomas.local What's odd is, if I rename the CSS file or the intel logo file within that directory, I can see the element disappear in a browser refresh. I'd really like to understand the node.js control file for the root page.

I'm not stressing over this, I'd just like to understand what's going on. Note too, that I've been playing around with my Edison board, (creating samples in the Arduino IDE and the XDK IoT edition IDE) so it wouldn't surprise me if there were an interference somewhere. It would be cool if I could see all the processes currently running on the Edison. I suspect I've got multiple node implementations running (but I'm really not sure.) Where is the "Control Alt Delete --> Task Manager" key on these new fangled things when you need it? Oops. I'm not thinking. http://linuxlookup.com/howto/view_running_processes_linux_system Its right here...

$ ps | less (if you want to view on your command line interpreter tool... )

$ ps > processlist.txt (for easy viewing later.. ftp the file back somewhere convenient)

This makes it much easier to see what's going on. My suspicion is for an actual project you'd reformat the Edison system, start afresh. Less is more.

Oooh.. and one more update. I was finally able to load up the Eclipse C/C++ stuff. Not sure why it wouldn't load during the large integrated download package at initial install. When I went to https://software.intel.com/en-us/installing-the-eclipse-ide IoT - Installing Eclipse* | Intel® Developer Zone everything works just fine. I was totally able to get the blinky thing to work in C++. Nice one.

LB

Sergio_A_Intel
Employee
54 Views

I tried to rename the logo-intel.png file and refreshing the browser and as expected, the logo disappeared from the Device Information page. Looking at the index.html file I couldn't find the function that called this .png file. I found this guide https://software.intel.com/en-us/getting-started-with-ap-mode-for-intel-edison-board IoT - Getting started with Access Point (AP) Mode for the Intel® Edison board | Intel® Developer Zone that has steps to connect to a network through the same device information page so maybe this was part of the code you see in index.html. Did you enter AP mode at before following the steps from the videos?

Sergio

Carlos_M_Intel
Employee
54 Views

Hi LBC,

Have you been able to work on this?

Did you check the guide posted by Sergio?

Regards,

Charlie

Reply