Community
cancel
Showing results for 
Search instead for 
Did you mean: 
GErks
Novice
1,738 Views

Galileo IoT DevKit Image problem with drivers

I have a problem with intel Galileo Gen 2 drivers.

 

when I use the yocto small Image with 48 MB my computer can recognize the Galileo board and upload sketches from the IDE to it, but if I'm using the large Image IOt DevKit with 238 MB my computer dose not recognize the Galileo and the driver will show : Unknown USB Device (Device Descriptor Request Failed)

 

and I have tried to download the drivers from the Galileo software and my Galileo firmware is up to date:

https://downloadcenter.intel.com/download/24748 Download Intel® Galileo Firmware and Drivers 1.0.4

Small Image:

http://www.intel.com/content/www/us/en/support/boards-and-kits/intel-galileo-boards/000005614.html Software Downloads for Intel® Galileo Gen 2 Board

Large Image:

https://software.intel.com/en-us/get-started-galileo-windows IoT - Getting Started with the Intel® Galileo Board on Windows* | Intel® Developer Zone

Regards,

Ghiath

16 Replies
FTinetti
Honored Contributor I
156 Views

Hi Ghiath,

Please send a picture of the device manager before and after you plug the USB of the Galileo with the "Large Image" (aka, egclibc image).

Fernando.

GErks
Novice
156 Views

This is the device manager when i plug the yocto :

when i plug eglibc image:

FTinetti
Honored Contributor I
156 Views

Both are yocto Linux with different packages/libraries, for different purposes, I think.

Try to upgrade the driver with the driver in the SD itself.

If the previous attempt does not work, try to use the drivers already installed (search among the installed drivers in your computer)

HTH,

Fernando.

idata
Community Manager
156 Views

Hi Ghiath,

 

 

Do you still need help with this thread, are the drivers recognized if you use the eglibc image?

 

 

Sergio

 

CJere1
Novice
156 Views

Yo tengo un problema parecido, y ya lo he intentado actualizando el firmware pero me muestra esto, y subiendo la imagen a la SD.

I have a similar issue. I have tried updating firmware and uploading image to SD card but it shows this in Device Manager.

thank you

FTinetti
Honored Contributor I
156 Views

Hi Camilo,

What image are you usign? Please send the link from where you downloaded it.

Fernando.

FTinetti
Honored Contributor I
156 Views

Hi,

I think that is the initial page, no yocto image there...

Please create a new thread with:

a) the step-by-step guide you followed up to the point where you get the screen you posted above

b) the screen you posted above

It should be clear from what you post whether or not you upgraded the firmware as well as the yocto image you are using (eglibc or uclibc)

Fernando.

idata
Community Manager
156 Views

Hi CamiloJez,

 

 

Were you able to follow FGT's suggestion, do you still need help with this thread?

 

 

Sergio

 

MBlak2
New Contributor I
156 Views

Very common for me, too...

Right click that CDC Serial Device and Update Driver Software

Choose Browse my computer for driver software

Choose Let me pick from a list of device drivers on my computer

Choose Intel Corporation and Galileo Click Next

Click Yes

I should be okay, now...but you can also change the Com Port assigned to a lower (but free) number.

Hope that helps -- the Com Port is very fragile on my system, too. Wireless SSH is far better, imho.

GErks
Novice
156 Views

I've tried this in my case and it doesn't work.

 

I think that I can't run normal ardujino sketch using usb port if i have eglibc image installed
GErks
Novice
156 Views

yes I think there no way that I can sent arduino sketches from the ide using usb port if I have eglibc Image installed

GErks
Novice
156 Views

This doesn't work for me too

MBlak2
New Contributor I
156 Views

I see...sorry about that, then. I was replying to the other post, actually. That is my procedure for when the COM port gets trashed in my setup, but -- I don't ordinarily even use the Arduino IDE when there is mraa available in node, python and through SSH. There is an other path in that, though -- not sure it will help you either -- but, you can also reinstall the drivers from the current installation path to the Arduino IDE for Galileo. It is the second or third image, where I say Choose Let me choose...

There is also a nice tutorial at SparkFun that has other interesting options that might be a better idea in your case. I think that Galileo boot configuration is in /etc/inittab in my distro.

FTinetti
Honored Contributor I
156 Views

Ghiath wrote:

This doesn't work for me too

Just to confirm: I sent:

Try to upgrade the driver with the driver in the SD itself.

If the previous attempt does not work, try to use the drivers already installed (search among the installed drivers in your computer)

and you tried both methods and neither of them worked, right?

Fernando.

MBlak2
New Contributor I
156 Views

Oh, wait a minute...I think I can help you. Because I think that image you put on is not correct. Can you look at that microSD card in Windows? Does it look like this? Just one partition?

Reply