Community
cancel
Showing results for 
Search instead for 
Did you mean: 
BSkrz
Novice
965 Views

Galileo gen 2 - LEDs don't light up

My galileo board worked fine for some time.

Yesterday I downloaded gentoo image for galileo gen 2 and started it from sd card, but I didn't have time to check if it actually works. As I went somewhere else I forgot to unplug my board (it wasn't connected to USB, only AC adapter). Today I went back and discovered that no led is on. I double checked that everything is connected, and measured oltage on input - it was a bit higher than 12V. I disconnected it and connected again. The green "ON" LED turned on for a fraction of a second and then slowly turned off. It didn't react to pressing REBOOT/RESET buttons. After disconnecting and connecting it again a few times it stopped working completely.

Is it completely broken? Did I do something wrong?

Tags (1)
3 Replies
BSkrz
Novice
59 Views

I have noticed that when I connect it something near the power connector gets really hot (so hot that I don't want to risk touching it again). Is it normal?

Pedro_M_Intel
Employee
59 Views

Hello Barteks2x,

I looks like your board's voltage regulator got damaged therefore when you plug it there's short circuit which causes the heat. I'd suggest you to submit an email to http://www.intel.com/support/mailform/maker/warrantyemail.htm Intel® Support.

Peter.

BSkrz
Novice
59 Views

I don't think it will help me...

Warranty is only one year and I have it more than one year. And even if it was still under warranty, I got it from friend from other country so sending it would be problematic.

I myself don't have the things I would need to repair it myself, and sending it for repair + repair cost would liklely be close to (or exceed) the cost of new galileo gen 2 board.

I read this: , the same part was getting so hot so I tried to power it directly from 5V source. The "ON" led still turned on for less than a second and then nothing. I measured the current to see if there is some short circuit - current was something around 0.1-0.2A. So it doesn't seem to be that.

Reply