Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
2,284 Views

Galileo gen1 arduino ide problem

Jump to solution

Firstly I want to say that I worked in the past with the arduino ide on some arduino uno projects, so i am not a complete newbie when it comes to arduino ide.

I just got an intel galileo gen1 board from my university and I wanted to test the blink project. I installed the board using this guide https://software.intel.com/en-us/articles/intel-galileo-board-assembly IoT - Intel® Galileo Board Assembly using Arduino* | Intel® Developer Zone after i opened the ide, I checked the tools->board/port to be the right ones. I uploaded the program but it fails, i get this error:

Arduino: 1.6.4 (Windows 8.1), Board: "Intel® Galileo"

i586-poky-linux-uclibc-g++: error: C:\Users\isara\AppData\Local\Temp\build5158321505411607872.tmp/core.a: No such file or directory

Error compiling.

This report would have more information with

"Show verbose output during compilation"

enabled in File > Preferences.

.

My os is win10 x64.


Accepted Solutions
Highlighted
Employee
25 Views

Hi kiradead,

I noticed that the log shows "Windows 8.1", but you confirmed you are using Windows 10. That might be the reason of this issue. Anyhow, I recommend you to download the Arduino IDE 1.6.0 and check if you get the same error: http://downloadmirror.intel.com/24783/eng/IntelArduino-1.6.0-Windows.7z http://downloadmirror.intel.com/24783/eng/IntelArduino-1.6.0-Windows.7z

Additionally, post a screenshot of the Device Manager while the board is powered with the DC power supply and the USB client is connected to the PC. I'd like to check the COM port status.

Regards,

Diego

View solution in original post

5 Replies
Highlighted
Employee
26 Views

Hi kiradead,

I noticed that the log shows "Windows 8.1", but you confirmed you are using Windows 10. That might be the reason of this issue. Anyhow, I recommend you to download the Arduino IDE 1.6.0 and check if you get the same error: http://downloadmirror.intel.com/24783/eng/IntelArduino-1.6.0-Windows.7z http://downloadmirror.intel.com/24783/eng/IntelArduino-1.6.0-Windows.7z

Additionally, post a screenshot of the Device Manager while the board is powered with the DC power supply and the USB client is connected to the PC. I'd like to check the COM port status.

Regards,

Diego

View solution in original post

Highlighted
Honored Contributor I
25 Views

Hi,

I've seen this error reported previously: , did you already upgrade the Galileo firmware?

Fernando.

0 Kudos
Highlighted
Employee
25 Views

Hi kiradead,

I'd like to know if you still need help with your board, or if you were able to fix the issue.

Regards,

Diego

0 Kudos
Highlighted
Beginner
25 Views

Sorry for not replying early, the ide you recommended works. I do have another question, is normal for the compilation,linking etc and uploading to take almost 1min?

0 Kudos
Highlighted
Employee
25 Views

Hi kiradead,

Yes, that's normal. The process of uploading a sketch takes around 1 minute.

Regards,

Diego

0 Kudos