Community
cancel
Showing results for 
Search instead for 
Did you mean: 
SJewe
Novice
967 Views

Help Getting Started - Issues with Blink Sketch

Hi - my son and I are just getting our Galileo Gen2 board up and going. When we try to do the blink sketch in Arduino, we get this error. Any ideas? We're running MacOS 10.10.5

I am not a programmer so need a bit of help getting this set up correctly. I think there is something wrong with the file structure for the active developer path, but i'm not quite sure how to fix it.

Thank you!

Suzi

Arduino: 1.6.12 (Mac OS X), Board: "Intel® Galileo Gen2"

/Applications/Arduino.app/Contents/Java/arduino-builder -dump-prefs -logger=machine -hardware /Applications/Arduino.app/Contents/Java/hardware -hardware /Users/Jewett/Library/Arduino15/packages -tools /Applications/Arduino.app/Contents/Java/tools-builder -tools /Applications/Arduino.app/Contents/Java/hardware/tools/avr -tools /Users/Jewett/Library/Arduino15/packages -built-in-libraries /Applications/Arduino.app/Contents/Java/libraries -libraries /Users/Jewett/Documents/Arduino/libraries -fqbn=Intel:i586:izmir_fg -vid-pid=0X8086_0XBABE -ide-version=10612 -build-path /var/folders/y9/5v23hdp15hq2tdsyy4d0w85w0000gn/T/arduino_build_988832 -warnings=none -prefs=build.warn_data_percentage=75 -prefs=runtime.tools.sketchUploader.path=/Users/Jewett/Library/Arduino15/packages/Intel/tools/sketchUploader/1.6.2+1.0 -prefs=runtime.tools.i586-poky-linux-uclibc.path=/Users/Jewett/Library/Arduino15/packages/Intel/tools/i586-poky-linux-uclibc/1.6.2+1.0 -verbose /var/folders/y9/5v23hdp15hq2tdsyy4d0w85w0000gn/T/arduino_modified_sketch_967967/Blink.ino

/Applications/Arduino.app/Contents/Java/arduino-builder -compile -logger=machine -hardware /Applications/Arduino.app/Contents/Java/hardware -hardware /Users/Jewett/Library/Arduino15/packages -tools /Applications/Arduino.app/Contents/Java/tools-builder -tools /Applications/Arduino.app/Contents/Java/hardware/tools/avr -tools /Users/Jewett/Library/Arduino15/packages -built-in-libraries /Applications/Arduino.app/Contents/Java/libraries -libraries /Users/Jewett/Documents/Arduino/libraries -fqbn=Intel:i586:izmir_fg -vid-pid=0X8086_0XBABE -ide-version=10612 -build-path /var/folders/y9/5v23hdp15hq2tdsyy4d0w85w0000gn/T/arduino_build_988832 -warnings=none -prefs=build.warn_data_percentage=75 -prefs=runtime.tools.sketchUploader.path=/Users/Jewett/Library/Arduino15/packages/Intel/tools/sketchUploader/1.6.2+1.0 -prefs=runtime.tools.i586-poky-linux-uclibc.path=/Users/Jewett/Library/Arduino15/packages/Intel/tools/i586-poky-linux-uclibc/1.6.2+1.0 -verbose /var/folders/y9/5v23hdp15hq2tdsyy4d0w85w0000gn/T/arduino_modified_sketch_967967/Blink.ino

Using board 'izmir_fg' from platform in folder: /Users/Jewett/Library/Arduino15/packages/Intel/hardware/i586/1.6.7+1.0

Using core 'arduino' from platform in folder: /Users/Jewett/Library/Arduino15/packages/Intel/hardware/i586/1.6.7+1.0

Detecting libraries used...

"/Users/Jewett/Library/Arduino15/packages/Intel/tools/i586-poky-linux-uclibc/1.6.2+1.0/i586/pokysdk/usr/bin/i586-poky-linux-uclibc/i586-poky-linux-uclibc-g++" -m32 -march=i586 "--sysroot=/Users/Jewett/Library/Arduino15/packages/Intel/tools/i586-poky-linux-uclibc/1.6.2+1.0/i586/i586-poky-linux-uclibc" -c -g -Os -w -fno-exceptions -ffunction-sections -fdata-sections -D__ARDUINO_X86__ -Xassembler -mquark-strip-lock=yes -w -x c++ -E -CC -march=i586 -m32 -DARDUINO=10612 "-I/Users/Jewett/Library/Arduino15/packages/Intel/hardware/i586/1.6.7+1.0/cores/arduino" "-I/Users/Jewett/Library/Arduino15/packages/Intel/hardware/i586/1.6.7+1.0/variants/galileo_fab_g" "/var/folders/y9/5v23hdp15hq2tdsyy4d0w85w0000gn/T/arduino_build_988832/sketch/Blink.ino.cpp" -o "/dev/null"

Generating function prototypes...

"/Users/Jewett/Library/Arduino15/packages/Intel/tools/i586-poky-linux-uclibc/1.6.2+1.0/i586/pokysdk/usr/bin/i586-poky-linux-uclibc/i586-poky-linux-uclibc-g++" -m32 -march=i586 "--sysroot=/Users/Jewett/Library/Arduino15/packages/Intel/tools/i586-poky-linux-uclibc/1.6.2+1.0/i586/i586-poky-linux-uclibc" -c -g -Os -w -fno-exceptions -ffunction-sections -fdata-sections -D__ARDUINO_X86__ -Xassembler -mquark-strip-lock=yes -w -x c++ -E -CC -march=i586 -m32 -DARDUINO=10612 "-I/Users/Jewett/Library/Arduino15/packages/Intel/hardware/i586/1.6.7+1.0/cores/arduino" "-I/Users/Jewett/Library/Arduino15/packages/Intel/hardware/i586/1.6.7+1.0/variants/galileo_fab_g" "/var/folders/y9/5v23hdp15hq2tdsyy4d0w85w0000gn/T/arduino_build_988832/sketch/Blink.ino.cpp" -o "/var/folders/y9/5v23hdp15hq2tdsyy4d0w85w0000gn/T/arduino_build_988832/preproc/ctags_target_for_gcc_minus_e.cpp"

"/Applications/Arduino.app/Contents/Java/tools-builder/ctags/5.8-arduino10/ctags" -u --language-force=c++ -f - --c++-kinds=svpf --fields=KSTtzns --line-directives "/var/folders/y9/5v23hdp15hq2tdsyy4d0w85w0000gn/T/arduino_build_988832/preproc/ctags_target_for_gcc_minus_e.cpp"

Compiling sketch...

"/Users/Jewett/Library/Arduino15/packages/Intel/tools/i586-poky-linux-uclibc/1.6.2+1.0/i586/pokysdk/usr/bin/i586-poky-linux-uclibc/i586-poky-linux-uclibc-g++" -m32 -march=i586 "--sysroot=/Users/Jewett/Library/Arduino15/packages/Intel/tools/i586-poky-linux-uclibc/1.6.2+1.0/i586/i586-poky-linux-uclibc" -c -g -Os -w -fno-exceptions -ffunction-sections -fdata-sections -MMD -D__ARDUINO_X86__ -Xassembler -mquark-strip-lock=yes -march=i586 -m32 -DARDUINO=10612 "-I/Users/Jewett/Library/Arduino15/packages/Intel/hardware/i586/1.6.7+1.0/cores/arduino" "-I/Users/Jewett/Library/Arduino15/packages/Intel/hardware/i586/1.6.7+1.0/variants/galileo_fab_g" "/var/folders/y9/5v23hdp15hq2tdsyy4d0w85w0000gn/T/arduino_build_988832/sketch/Blink.ino.cpp" -o "/var/folders/y9/5v23hdp15hq2tdsyy4d0w85w0000gn/T/arduino_build_988832/sketch/Blink.ino.cpp.o"

xcrun: error: active developer path ("/Volumes/Xcode/Xcode.app/Contents/Developer") does not exist, use `xcode-select --switch path/to/Xcode.app` to specify the Xcode that you wish to use for command line developer tools (or see `man xcode-select`)

exit status 1

Error compiling for board Intel® Galileo Gen2.

8 Replies
idata
Community Manager
43 Views

Hello InterestedMom,

 

 

Thanks for reaching out!

 

 

I have never seen this error message when using the Arduino IDE on my MAC, I'd like to ask you if you made sure to install the latest versions of the board packages. In case you haven't, go to Tools > Board: > Board Manager... This will open a new Window, on the Type combo box, select Arduino Certified, now you should see an option called Intel i586 boards. In case you have already installed it previously you will see an update button, make sure you install version 1.6.7+1.0.

 

 

Please try this and let us know what happens. Also, the Arduino IDE on MAC needs a legacy version of Java, have you installed this already? In case you haven't, please let me know and I'll gladly send you the link for this Java version.

 

 

We'll be waiting for your reply.

 

-Peter.
SJewe
Novice
43 Views

Thanks for hte reply. I did install the latest version of the arduino.

I havne't done anything with Java though.

Thanks!

idata
Community Manager
43 Views

Thank you for letting us know, please make sure to update the board packages by following the procedure found in my previous post. The Java version the Arduino IDE needs can be found in https://support.apple.com/kb/DL1572?locale=en_US, please install it and try again.

 

 

Let us know.

 

-Peter.
idata
Community Manager
43 Views

Hello InterestedMom,

 

 

Do you have any updates about this?

 

 

-Peter.
SJewe
Novice
43 Views

Hi - we did the Java update and are still getting the same error. I think this is the specific area of issue:

xcrun: error: active developer path ("/Volumes/Xcode/Xcode.app/Contents/Developer") does not exist, use `xcode-select --switch path/to/Xcode.app` to specify the Xcode that you wish to use for command line developer tools (or see `man xcode-select`)

exit status 1

Error compiling for board Intel® Galileo Gen2.

Where woudl i update this path? Or am I missing a library that I somehow need to create?

Thank you!

idata
Community Manager
43 Views

I find this behavior very strange, I have never seen an issue similar to this on my Mac. I just tested it on a Mac running OSX 10.12.1 Sierra as you can see in the screenshot below. Is it possible for you to update your Mac? Another thing that might help is to remove the Arduino IDE from the system and install it again. Could you please try that?

Let us know how it goes.

 

-Peter.
SJewe
Novice
43 Views

Yeah - that worked (just reloaded the arduino, for some reason i can't upgrade my mac to sierra)

I did get this warning, but the blink sketch did work.

Warning: file /Users/Jewett/Library/Arduino15/packages/Intel/tools/i586-poky-linux-uclibc/1.6.2+1.0/i586/pokysdk/etc/ld.so.cache links to an absolute path /etc/ld.so.cache

So now we need to get some sensors and have some fun. For a 9 yr old, would you recommend going with the grove starter pack? Are there any other sketches we acn run to get hin started witthout add'l HW?

Thank you!!!

idata
Community Manager
43 Views

I'm glad to hear that you are now able to use the Arduino IDE on your Mac. The warning you received is normal, as long as you don't receive an error message everything should be fine.

 

 

Yes, the Grove kit is a good place to start with Galileo. However, if you would like to buy more sensors or shields in the future, I'd recommend you to read the Shield Testing Report for Intel® Galileo Board, Intel® Galileo Gen 2 Board, and Intel® Edison Board ( http://www.intel.com/content/www/us/en/support/boards-and-kits/000020775.html) first. In this document you will find information about sensors and shields that have been tested officially with Galileo. You can use it as a guide to determine whether a sensor/shield will work on your Galileo or not.

 

 

I hope this information is useful for you. Let us know if you need anything else.

 

-Peter.