Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Community Manager
1,530 Views

How to add the NFS support for the target image and the ext3 filesystem?

Hi everyone,

I'm trying to add the NFS support for the Galileo. Is there any How-To to describe the task since I'm a new developer for the Galileo platform? Here are what I have done:

1. Get the new config file for linux image through "bitbake linux-yocto-quark -c menuonfig"

2. Enable the NFS support config options by adding an extra nfs-extra.cfg file under:

meta-iot-devkit/recipes-kernel/linux/linux-yocto-quark/iot-devkit. and include the config file in linux-yocto-quark_3.8.bbappend

Here are the contents for the file:

CONFIG_NFS_FS=y

CONFIG_NFS_V2=y

CONFIG_NFS_V3=y

3. Bitbake image-full. After booting the new image, I've checked the system through "cat /proc/filesystems". And the NFS was supported by the new kernel.

4. mount a remote network file system by doing "mount -t nfs ...". But this command failed. It prompts some helper should be provided.

It seems I have to add some extra binutils support for the mount?

Thanks,

James Jiao.

5 Replies
Highlighted
Employee
16 Views

Hi BG4BMH,

Which Quark BSP did you use to build the image? Also, could you attach a screenshot of the error? Finally, if you build an uclibc image, have you tried installing util-linux-mount from AlexT http://alextgalileo.altervista.org/package-repo-configuration-instructions.html repo? In case you haven't, you can install it with the following command:

opkg install http://repo.opkg.net/galileo/repo/i586/util-linux-mount_2.22.2-r3_i586.ipk http://repo.opkg.net/galileo/repo/i586/util-linux-mount_2.22.2-r3_i586.ipk

Remember to set up the internet connection before running the command.

Regards,

 

JPMontero_Intel
Highlighted
Community Manager
16 Views

Hi JPMontero_Intel,

Here is the console output:

////first make sure the nfs was supported by the kernel:

root@quark:/bin# cat /proc/filesystems

nodev sysfs

nodev rootfs

nodev bdev

nodev proc

nodev cgroup

nodev cpuset

nodev tmpfs

nodev devtmpfs

nodev debugfs

nodev sockfs

nodev pipefs

nodev anon_inodefs

nodev rpc_pipefs

nodev devpts

ext3

ext2

nodev ramfs

nodev hugetlbfs

vfat

nodev nfs

nodev autofs

fuseblk

nodev fuse

nodev fusectl

nodev mqueue

nodev efivarfs

/////second, mount the remote nfs filesystem:

root@quark:/bin# mount -t nfs 192.168.0.105:/srv/quarkimage /mnt -o rw,nosuid

mount: wrong fs type, bad option, bad superblock on 192.168.0.105:/srv/quarkimage,

missing codepage or helper program, or other error

(for several filesystems (e.g. nfs, cifs) you might

need a /sbin/mount. helper program)

In some cases useful info is found in syslog - try

dmesg | tail or so.

root@quark:/bin#

I used the

DISTRO ?= "iot-devkit-multilibc"

to compile the full image.

Is there anything I've missed?

Best regards,

James Jiao

0 Kudos
Highlighted
Employee
16 Views

Hi BG4BMH,

Thanks for the additional information, the only thing missing is the BSP version, are you using BSP 1.1.0 or BSP 1.2.0?

Regards,

 

JPMontero_Intel
0 Kudos
Highlighted
Community Manager
16 Views

Hi,

I use the 1.1.0 bsp.

Regards,

James Jiao

0 Kudos
Highlighted
Employee
16 Views

Hi BG4BMH,

Make sure you added all NFS dependencies in the menuconfig. Additionally I'd try installing nfs-export-root and nfs-utils from the https://github.com/openembedded/openembedded-core openembedded-core layer. Then build the image with both packages.

Regards,

 

JPMontero_Intel
0 Kudos