Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
170 Views

How to bulid mono-fastcgi-server

i am trying to build mono web applications with nginx for linux platform with yocto worrier branch

i have made changes on below conf file

1)conf/local.conf

 

PACKAGE_CLASSES ?= "package_deb"

EXTRA_IMAGE_FEATURES ?= "tools-sdk"

CORE_IMAGE_EXTRA_INSTALL += "mono mono-xsp libtool ca-certificates mono-dev sqlite autoconf automake make libevent-dev libgdiplus libxft libevent packagegroup-core-buildessential libxml2 libgdiplus nginx "

 

2) conf/bblayers.conf

BBLAYERS ?= " \

/home/administrator/yocto-warrior/poky/meta \

/home/administrator/yocto-warrior/poky/meta-poky \

/home/administrator/yocto-warrior/poky/meta-yocto-bsp \

/home/administrator/yocto-warrior/meta-openembedded \

/home/administrator/yocto-warrior/meta-oe \

/home/administrator/yocto-warrior/meta-mono \

/home/administrator/yocto-warrior/meta-intel \

/home/administrator/yocto-warrior/openembedded-core \

 

ERROR:

ERROR: mono-xsp-git-r0 do_configure: oe_runconf failed

ERROR: mono-xsp-git-r0 do_configure: Function failed: do_configure (log file is located at /home/administrator/yocto-warrior/build/tmp/work/core2-64-poky-linux/mono-xsp/git-r0/temp/log.do_configure.18661)

ERROR: Logfile of failure stored in: /home/administrator/yocto-warrior/build/tmp/work/core2-64-poky-linux/mono-xsp/git-r0/temp/log.do_configure.18661

ERROR: Task (/home/administrator/yocto-warrior/meta-mono/recipes-mono/mono-xsp/mono-xsp_git.bb:do_configure) failed with exit code '1'

ERROR: monotools-server-2.0-r0 do_populate_lic: QA Issue: monotools-server: The LIC_FILES_CHKSUM does not match for file://install-sh;md5=361482dd6b5b5eb7090fff3986fba68a

monotools-server: The new md5 checksum is 5cc51dc6eb45a90231a4e31efbc3f220

monotools-server: Here is the selected license text:

vvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvv

#!/bin/sh

# install - install a program, script, or datafile

 

scriptversion=2006-12-25.00

 

# This originates from X11R5 (mit/util/scripts/install.sh), which was

# later released in X11R6 (xc/config/util/install.sh) with the

# following copyright and license.

#

# Copyright (C) 1994 X Consortium

...

  trap '' 0

 

 

0 Kudos
1 Reply
Highlighted
Moderator
8 Views

Re: How to bulid mono-fastcgi-server

Hi @ARath16​ ,

 

Thanks for reaching out. Based on the error you provided it looks like the package md5 checksum has changed. You will need to update this on the .bb recipe file, which I believe is mono-xsp_git.bb file found in /home/administrator/yocto-warrior/meta-mono/recipes-mono/mono-xsp/mono-xsp_git.bb. Try updating the package checksum from 361482dd6b5b5eb7090fff3986fba68a to 5cc51dc6eb45a90231a4e31efbc3f220 and rebuild.

The LIC_FILES_CHKSUM does not match for file://install-sh;md5=361482dd6b5b5eb7090fff3986fba68a monotools-server: The new md5 checksum is 5cc51dc6eb45a90231a4e31efbc3f220

 

Regards,

@Luis_at_Intel​ 

0 Kudos