Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
949 Views

How to code samples not compiling.

Hello,

I have installed Intel System Studio IoT Edition on a Ubuntu 16.04 according to instructions given here https://software.intel.com/en-us/intel-system-studio-iot-edition-guide-for-c IoT - Intel® System Studio IoT Edition User Guide for C/C++ | Intel® Software

I am now trying to compile some of the How to code samples (cpp ones); but I am facing a lot of errors during compilation.

I have the feeling that they are not maintained any more.

Examples:

  • Range Finder Scanner:

The name of the variable in the file src/html.h looks really strange (this is like _/aaa/bbb/ccc/index_html[] = { ... ) and generates compilation error.

There is a reference to this script hex2c.sh to regenerate html.h, but I can't find anywhere this script in the src folder or even in the gitrepo in github.

  • BLE scan bracelet:

There are compilation errors when including /usr/include/bluetooth/bluetooth.h file. Can figure out why.

By the way the java version of this project is also not compiling due to a missing jar (tinyb.jar) I can't find anywhere in ISS (and according to README.md it should be provided).

  • Access control

Same story. Compilation error when including /usr/include/upm/upm_platform.h with "UPM: Unknown Platform"

Either I have missed some important point or the samples are not up to date any more!

And for information my Edison board packages are synchronized

Is there anyone able to compile these samples on Linux?

4 Replies
Highlighted
Community Manager
22 Views

Hi Sideralis,

 

 

Thank you for reporting this. Are the examples you mentioned the only ones that fail to compile? Are the errors for the 3 examples the same, please attach a screenshot of the error. If it's not the same error, attach a picture or the output of each error individually.

 

 

Do you see the errors after following the instructions from here:

 

https://github.com/intel-iot-devkit/how-to-code-samples/tree/master/range-finder-scanner/cpp https://github.com/intel-iot-devkit/how-to-code-samples/tree/master/range-finder-scanner/cpp

 

https://github.com/intel-iot-devkit/how-to-code-samples/tree/master/ble-scan-bracelet/cpp https://github.com/intel-iot-devkit/how-to-code-samples/tree/master/ble-scan-bracelet/cpp

 

https://github.com/intel-iot-devkit/how-to-code-samples/tree/master/access-control/cpp https://github.com/intel-iot-devkit/how-to-code-samples/tree/master/access-control/cpp

 

 

You mentioned that your packages are synchronized so you've already followed https://software.intel.com/en-us/node/705853 https://software.intel.com/en-us/node/705853 . Just to double check, which UPM and MRAA versions do you have installed? Also, which image are you using on your Edison?

 

 

We'll be waiting for your response.

 

 

-Sergio

 

0 Kudos
Highlighted
22 Views

Hello Sergio,

The examples I mentionned are the ones I tried to compile and failed (but for example the blink led example or HelloWorld are working).

I followed the instructions from the links you gave.

But since yesterday I made some progresses:

  • ble-scan-bracelet is now compiling by fixing the docker container: I edit the file /usr/include/bluetooth/bluetooth.h and replace "typeof" by "__typeof__". Now it is compiling. I have not yet tried to run it. And by the way the file .../bluetooth.h on my Edison board is correct. So it looks like the docker container and the Edison image are not in sync.
  • access-control is also now compiling. I needed to add a new symbol (linux) in Eclipse to have it compiling.

For attaching error, I think it will be faster for you to reproduce it than for me to make a copy paste.

Packages are synchronized as explained in your link.

upm is version 1.0.2

mraa is version 1.5.1

For Edison image, I noticed that the image you get by the installer: https://software.intel.com/edison-config/linux/latest https://software.intel.com/edison-config/linux/latest and the one you get by this link: https://software.intel.com/edison-image/latest https://software.intel.com/edison-image/latest are not the same. But anyway, I tried both and same result.

Bernard.

0 Kudos
Highlighted
Community Manager
22 Views

Hi Bernard,

 

 

Thank you for following the instructions we sent. We tried to run the examples you mentioned plus a few others and got the error you described. The error was the same "UPM: Unknown Platform" you mentioned in your first post. Other examples besides the three you initially mention also have this problem.

 

 

I've not tried yet the workaround you posted for ble-scan-bracelet and access-control but, we'll take it as feedback when we report the situation to the proper team. I'm sure it'll also help other users that try to use the examples on the ISS IoT.

 

 

Regards

 

 

-Sergio

 

0 Kudos
Highlighted
Community Manager
22 Views

Hi Sideralis,

 

 

This issue is in consideration for a future release of Edison software. Thank you for your understanding and feedback.

 

 

-Sergio

 

0 Kudos