Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Novice
2,593 Views

How to enable IPv6 on intel edison

I want to connect my intel edison a network ipv6 but I can not.

 

I said to check the status wpa_cli

 

Please help
0 Kudos
23 Replies
Highlighted
Community Manager
19 Views

Hi,

 

 

What image are you using? What method are you using to connect, can you list all the steps you've followed so far?

 

 

In the eglibc image, for example, IPv6 is enabled on network interfaces by default as inet6 addr.

 

 

-Sergio

 

0 Kudos
Highlighted
Novice
19 Views

Hi,

The card is loaded with the Yocto-linux - opkg.

I did an Access Point with ipv6 and when I want to connect using the command configure_edison --wifi I get I can not connect.

I said to check the "wpa_cli status"

0 Kudos
Highlighted
Community Manager
19 Views

Specifically, what image are you using? You can check with cat /etc/version. When you try to connect to a local network you have to make sure that the network is providing IPv6 addresses. Can you send a screenshot of the router's DHCP lease settings?

 

 

-Sergio

 

0 Kudos
Highlighted
Valued Contributor I
19 Views

In the image we tried (2.1 and our custom builds with eth) ipv6 is always enabled. However the edison badly confuses our router by continuously requesting a new address. And for such a small device does a great job of bringing our office network on its knees.

So, we needed to disable ipv6 to get a decent connection.

Haven't tried with 3.0 or 3.1 though.

0 Kudos
Highlighted
Community Manager
19 Views

Do you still need help with this thread, were you able to use IPv6?

 

 

-Sergio

 

0 Kudos
Highlighted
Novice
19 Views

I could still connect with Ipv6 edison intel card.

 

As I can verify the image I'm using?

 

The intel card edison does not have the cat / etc / folder version
0 Kudos
Highlighted
Community Manager
19 Views

You can check the image with cat /etc/version. Copy the command in bold and paste it in the terminal to avoid issues with spacing. If this doesn't provide any output, post a screenshot of the Linux terminal so take a closer look.

 

 

-Sergio

 

0 Kudos
Highlighted
Novice
19 Views

I got this result.

 

This is good or bad?
0 Kudos
Highlighted
Community Manager
19 Views

Hi sonykec,

 

 

That's the correct output for the version command, however that layout looks like the one from Ubuntu, not the one from the Edison's command line. Make sure that the configuration is done on the Edison's terminal window.

 

 

Regarding connection to IPv6 you can use connmanctl. See connmanctl –help for some guidelines on how to configure IPv6. Take a look at https://www.mankier.com/1/connmanctl https://www.mankier.com/1/connmanctl for more information.

 

 

-Sergio

 

0 Kudos
Highlighted
Novice
19 Views

The window is ubuntu.

To enter the intel card edison I open a terminal in ubuntu and from there I can access the card.

As I can enter the command line of Edison?

The operating system I'm using is Ubuntu.

0 Kudos
Highlighted
Community Manager
19 Views

Yes, that's a way to connect to the Edison, through an Ubuntu machine using the screen command, as explained here https://software.intel.com/en-us/setting-up-serial-terminal-on-system-with-linux https://software.intel.com/en-us/setting-up-serial-terminal-on-system-with-linux . Now you can proceed to use connmanctl to connect to IPv6.

 

 

Let us know your results.

 

 

-Sergio

 

0 Kudos
Highlighted
Novice
19 Views

By "connmanctl" command and I could connect to ipv6. But to do that I had to connect my network to an IPv4 address.

You must have an IPv4 address to connect with ipv6?

 

 

I set an Access Point to deliver me Ipv6 addresses.

 

In ubuntu I could connect me to the network without any problem by wifi.

 

 

Now I want to connect the card intel edison with the same network as I believe, I get the following error.

0 Kudos
Highlighted
Novice
19 Views

Once you connect me with the connmanctl command ipv6 I wanted to connect wirelessly to the card with ssh.

 

 

I could not do it. I came out this error.

 

 

SSH is enabled for IPv6?
0 Kudos
Highlighted
Community Manager
19 Views

Hi,

Specifically, how did you connect to the IPv6 network, what command did you use? Connecting first to an IPv4 network shouldn't be a requirement. You also mention you got an error and posted a screenshot, but the screenshot doesn't contain any errors, just the screen where you choose the network you wish to connect to. Which error did you receive?

 

Usually, when connecting through ssh through the Edison.local you need to have the output of the configure_edison –wifi (see image below)

 

 

Then, in this case, connect to ssh using the command ssh root@ EdisonEMC.local. In your case you don't have the same user name, so type the command for your username. Post screenshots of your progress and of the result of connecting to the IPv6 network, which is similar to the screenshot we posted above.

We'll be waiting for your response.

-Sergio

 

0 Kudos
Highlighted
Novice
19 Views

Hello,

 

 

I connect to the IPv6 network using the "connmanctl" command. (View image).

 

 

Then step to check with the "ifconfig" command and the connection is successful.

 

 

To connect using ssh, I use the command: ssh root @ 2000: 1 :: 7a4b: 87ff: fea2: 7d93 and the connection is also successful.

 

 

Now I find another problem.

 

How I can access the browser?

 

When I connect by ipv4 card he tells me the direction with which I can connect to the browser. For example http://edison.local.

But now that connect me with ipv6, how do I can do?

 

 

Do I have to modify any file on the card?
0 Kudos
Highlighted
Novice
19 Views

The intel edison card allows me to access the browser once set up. As seen in the image.

 

 

The question I asked earlier is related to this.

 

 

How do I do to access from the browser with an IPv6 address and the part where it says "IP Address" me IPv6 address set with the "connmanctl" command appears?
0 Kudos
Highlighted
Community Manager
19 Views

Hi sonykec,

 

 

There are two ways to display the device information page, through the IP or through the hostane.local name. If you look at my previous reply /message/417962# 417962 https://communities.intel.com/message/417962# 417962 you can see a screenshot with a message that says "Please connect your laptop or PC to the same network as this device and go to…"

 

To view the device information page you need to copy either the IP address or the hostane.local name (colored blue) into your browser, but instead of using the IPv4 address, use the IPv6 address. For example http:// or http://

 

 

I haven't tried to do this in IPv6 so try it out and let us know your results. You can also post screenshots of the results of each one. Remember that your Edison and PC need to be in the same network for this to work.

 

 

-Sergio

 

0 Kudos
Highlighted
Novice
19 Views

Hi,

I've tried what they told me. On the same network they are connected my PC and Intel Edison card. I realize the ping6 between the two elements and is satisfactory. As you can see in the images that I attached

 

ping6 between ""Intel Edison - PC""

ping6 between ""PC - Intel Edison""

Join correctly to the console via intel edison card with ssh root @

 

 

But when entering the Mozilla browser and typing the ipv6 address to access the card intel edison I do not get any results.

In either ways. attached images

1.

2.

 

 

When ipv4 income with the browser, the connection is successful.

What should I do to connect to the browser?

0 Kudos
Highlighted
Community Manager
19 Views

Hi sonykec,

 

 

Thank you for attaching the screenshots and describing your issue in detail. I've seen other users have trouble with accessing the browser through IP or hostname in the latest image using IPv4. Older versions had this feature working. If you're interested you can try to re-flash your Edison with an older image version just to check if the issue is because of the IPv6 or because of the latest Yocto image. You can download the older Yocto versions from the following link: https://software.intel.com/en-us/iot/hardware/edison/downloads https://software.intel.com/en-us/iot/hardware/edison/downloads

 

 

Try it out and let me know your results. Meanwhile, I'll try to keep looking for other possible causes of this behavior.

 

 

-Sergio

 

0 Kudos