Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
New Contributor II
945 Views

How to get sources and compile the latest yocto image

It has been a while since I worked with the edison. I made some notes about how to get the latest edison source files and compiling the yocto image. However, everything has been changed.

The latest http://www.intel.com/content/www/us/en/support/boards-and-kits/000005616.html Board Support Package (BSP) User Guide for Intel® Edison Development... still says that one has to download the edison-src.tgz but there is no link here:https://software.intel.com/en-us/iot/hardware/edison/downloads Downloads for Intel® Edison Module | IoT | Intel® Software

The category Build Your Own Yocto* Poky Image at least sounds like what I am interested in. But this seems just to be a SDK for programming after exectuing the *.sh file? For what is the file iot-devkit-toolchain-linux-64bit-edison-20160606.sh actually used for?

In short: Where do I get the latest yocto source files to compile the image?! Is there a more detailed description

0 Kudos
4 Replies
Highlighted
Valued Contributor I
8 Views

I like this http://git.yoctoproject.org/cgit/cgit.cgi/meta-intel-edison/ meta-intel-edison - Layer for the Intel Edison Development Platform

There is a setup script that will pull the other layer you probably need. I doesn't include everything included in the official image, but does pull a more recent kernel. MRAA seems to be lagging, but that could be fixed by pulling a more recent iot-middleware.

(we are using an older commit that pull kernel 3.10.14 and the old mraa, so haven't tried the latest and greatest)

0 Kudos
Highlighted
Community Manager
8 Views

Hi,

 

 

We'll be glad to help you with this. You can also try Ferry's approach on this.

 

Here's the source code for the image, http://iotdk.intel.com/src/3.5/edison/ http://iotdk.intel.com/src/3.5/edison/. Make sure to check the README instructions, there might be information not available in the BSP user guide.

 

Regarding your question about the iot-devkit-toolchain-linux-64bit-edison-20160606.sh file, this is used to set up the toolchain. So from your system use wget to download it and then run the script to set up the toolchain.

 

Let us know if you need any more help.

 

 

Regards,

 

-Pablo
0 Kudos
Highlighted
New Contributor I
8 Views

Hi,

I have used the link in Pablo's reply, (20160606). My first attempt was to follow the README instructions, but in the build process I kept bumping into a very stubborn error message, about trying to use the host includes and libs.

I thought it must have been an initialization problem of the environment, so followed the track in http://www.intel.com/content/www/us/en/support/boards-and-kits/000005616.html Board Support Package (BSP) User Guide for Intel® Edison Development... (quoted).

The difference is, that it starts with a meta-intel-edison/startup.sh script, which seeems to fix the environment. After a few minor issues this went all the way down. You can find my track in this topics: after post 12.

I found the BSD document a bit outdated, but basically all hickups could be fixed. (It is never flawless to build an embedded linux rootfs.)

Istvan

0 Kudos
Highlighted
Community Manager
8 Views

Hi Istvan,

 

 

Thank you very much for sharing your inputs and documentation on building the image with the sources I provided. This is especially important "The difference is, that it starts with a meta-intel-edison/startup.sh script, which seems to fix the environment."

 

 

Regards,

 

-Pablo
0 Kudos