Community
cancel
Showing results for 
Search instead for 
Did you mean: 
DDenn2
Beginner
1,341 Views

I have connected to my wi-fi network, but no internet functions work

Just got my replacement Compute Stick (Ubuntu 14.o4) Powered up flawlessly, appeared to connect to my wireless network fine, shows a good signal. However, no internet related functions work. Browser can't connect to sites, and software downloads don't work. I've rebooted a couple of times, without any change. Do I need to change settings somewhere, or is there a secret I don't know? Any help appreciated.

0 Kudos
15 Replies
idata
Community Manager
100 Views

Hi dnoonan,

 

 

Before the stick replacement, I suggest you update the BIOS to the latest version 0031.

 

 

STCK1A8LFC BIOS version 0031

 

https://downloadcenter.intel.com/download/25506/BIOS-Update-FCBYT10H-86A-?product=86613 https://downloadcenter.intel.com/download/25506/BIOS-Update-FCBYT10H-86A-?product=86613

 

 

Regards,

 

Mike C
DDenn2
Beginner
100 Views

Mike...

Thanks for your reply...is there a way to update the BIOS without internet connection? Obviously a Ubuntu/Linux newby here, so all assistance gratefully received.

idata
Community Manager
100 Views

Hi dnoonan,

 

 

It is possible to download the .BIO file using a second computer and keep the file in the root of a USB drive.

 

 

STCK1A8LFC BIOS version 0031

 

https://downloadcenter.intel.com/download/25506/BIOS-Update-FCBYT10H-86A-?product=86613 https://downloadcenter.intel.com/download/25506/BIOS-Update-FCBYT10H-86A-?product=86613

 

 

I suggest you the F7 or Power Button Menu options for the BIOS update; more details of the processes in the link below:

 

http://www.intel.com/content/www/us/en/support/boards-and-kits/intel-compute-stick/000005961.html http://www.intel.com/content/www/us/en/support/boards-and-kits/intel-compute-stick/000005961.html

 

 

Regards,

 

Mike C
DDenn2
Beginner
100 Views

I updated the BIOS as you suggested, seemed to go flawlessly, but no love, still shows a strong WI-FI signal, but no internet works. Open to any suggestions.

DeanG
New Contributor I
100 Views

Note: The opinions I express here are my own. I do not work, nor have I ever worked, for Intel Corporation.

You probably need to select or set the SSID, and perhaps the network IP address and associated data, either manually or by using DHCP. Have you done any of that?

If you have done that, you will need to check the gateway IP address (use the "route" command, and the "traceroute -n" command to a known IP address, like 8.8.8.8), and narrow down where the problem is.

If you do not know how to do that, this forum may not be the best place to ask questions. I would suggest the Ubuntu forums. Further, learning about Linux is much easier (due to the tools available) on a regular desktop computer, preferably with a wired network connection.

DDenn2
Beginner
100 Views

Dean: The SSID is correct, and I get an "Excellent" signal strength, and 150 mb/s. I entered the static IP info per the Netgear support site. I ran "route" with the following result:

Destination Gateway Genmask Flags metric Ref

Default 192.168.1.1 0.0.0.0 UG 0 0

192.168.1.0 * 255.255.255.0 U 0 0

Tried to run "Traceroute", but the package containing that command apparently is not installed on the stick, and since I can't connect, I can't install using apt-get.

I don't know what any of that means.

Feel free to respond with any suggestions.

Thanks for helping

DeanG
New Contributor I
100 Views

It looks from your reply like your IP address is 192.168.1.x (verify by running "ifconfig"), and your gateway is 192.168.1.1. Run these (Ctrl-C to exit):

ping 192.168.1.x (you can ping yourself)

ping 192.168.1.1 (you can ping the router)

ping 8.8.8.8 (you can ping Google)

AlHill
Super User
100 Views

I am just passing by, but I thought using 192.168.1.0 as a static address would stop the network from working until the device was taken offline.

However, I am old and not necessarily up-to-date.

Doc

DeanG
New Contributor I
100 Views

Ah, you are right in that 192.168.1.0 is the network address (since the netmask is 255.255.255.0), not the host IP address. He needs to run "ifconfig" to see his Stick's IP address. Then substitute that in the first ping line above.

DDenn2
Beginner
100 Views

OK- I ran he ifconfig: Inet add: 192.168.1.10 (this is the static address I set up per Netgear)

Bcast: 192.168.1.255

Mask: 255.255.255.0

I pinged all the items you listed, not sure what the pertinent responses are...I got an equal number of packets transmitted and received.with 0 packet loss. I let it run about 20 lines each time.

DeanG
New Contributor I
100 Views

If you were able to ping 8.8.8.8 and get responses back (eg, your zero packet loss), you have a connection to the Internet.

So, what makes you think that you don't have Internet functions?

ps: I hope you know that in Linux, almost everything (filenames, program names) is case-sensitive.

DDenn2
Beginner
100 Views

I can't connect to any internet sites, and get the message (in details) DNS_PROBE_FINISHED_NO_INTERNET

I thought when I got responses to the ping that showed a connection as well, but nothing connects. FWIW, using the Chromium browser that came with the Ubuntu install.

Thanks again for helping...

DeanG
New Contributor I
100 Views

Ok, it appears that you have an Internet connection (eg, via IP addresses), and your device is working just fine. However, you don't have anything running or configured that does DNS name resolution (eg, resolves Internet names like hostnames, URLs). Since you manually set the Stick's IP address rather than use DHCP, you will have to edit /etc/resolv.conf (either directly or with whatever GUI tool Ubuntu provides), and add the IP addresses of known DNS servers, preferably ones provided by your ISP.

Note that all this is done automatically for you, if you don't manually specify an IP address for the Stick, but instead use DHCP. However, get this working first by specifying one of Google's DNS servers (eg, 8.8.8.8) in /etc/resolv.conf. Type "man resolv.conf" to learn the details. This will also give you a good introduction into using "man", which is the primary way to learn the details of most Linux commands.

As I noted above, these are really Ubuntu configuration questions, and the Stick is not the ideal device to learn on..

idata
Community Manager
100 Views

Hello dnoonan:

 

 

I just wanted to let you, that the best thing to do in this case to get further information about a possible way to fix this problem, will be to access your Linux distro's website and forums for peer assistance with this issue at:

 

 

http://ubuntuforums.org/ http://ubuntuforums.org/

 

 

Regards

 

 

Alberto

 

linuxium
New Contributor III
100 Views

If you are using Network Manager to enter your static IP address, on the 'IPvx Settings' screen look under the box that says 'Addresses' and you will see a box called 'DNS Servers:' where you can enter the value (e.g. 8.8.8.8) in. If you are editing '/etc/network/interfaces' or similar then add a line 'dns-nameservers 8.8.8.8'.

Reply