Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Phuoc_N_Intel
Employee
1,061 Views

I tried to connect to a wifi for my edison-arduino 2 but unsuccessful.

I followed systemctl start wpa_supplicant from the web page, then up to enable_network command, I got the following:

<3>CTRL-EVENT-SCAN-RESULTS

<3>WPS-AP-AVAILABLE

<3>CTRL-EVENT-SCAN-RESULTS

<3>WPS-AP-AVAILABLE

>

then type quit to return to

> root@edison:~# ping www.google.com

ping: bad address 'www.google.com'

Would anyone please help me?

Thanks,

Phuoc

8 Replies
Pablo_M_Intel
Employee
106 Views

Hi pdnguyen,

Could you please tell us which guide are you following to complete this process? I believe you're using an outdated document. Please check this other one: https://software.intel.com/en-us/connecting-your-intel-edison-board-using-wifi IoT - Connecting your Intel Edison board using Wi-Fi* | Intel® Developer Zone. As long as there is a WiFi network available you shouldn't have any issue.

Regards,

PabloM_Intel

Phuoc_N_Intel
Employee
106 Views

I did try the one you suggested before and retried and here are what I don't understand:

After running configure_edison --wifi on the PuTTy terminal, then chose a number from a list for my network SSIDs

There is a question:

Password must be either 5 or 13 characters.

What is the network password?

My network password for wifi connection has 10 characters so when I type it, it does not accept. It only accepts exactly 5 letters or exactly 13 characters. I don't know why.

That was why i tried alternate method by using wpa_supplicant and it did not work either.

Thanks for your help.

Pablo_M_Intel
Employee
106 Views

Hi pdnguyen,

Could you please tell me which image you are using? When I setup my Edison's Wifi I'm not asked to enter a 5 or 13 character password. It's possible that you're using WEP and this is causing this behavior. Have you checked this thread /thread/59888 https://communities.intel.com/thread/59888?

Regards,

PabloM_Intel

Carlos_M_Intel
Employee
106 Views

Hi Phuoc,

Have you been able to connect your board to your network?

Do you still have the problem while entering the password?

Regards,

Charlie

Phuoc_N_Intel
Employee
106 Views

I tried to follow the thread /thread/59888 https://communities.intel.com/thread/59888? and edit /usr/bin/configure_edison

and I added lines for WEP_HEX and for password with 10 hex characters:

Now I see the following errors:

root@edison:/usr/bin# configure_edison --wifi

File "/usr/bin/configure_edison", line 68

WEP_HEX = '''

^

IndentationError: unindent does not match any outer indentation level

I know I have syntax errors and I looked at the location and have no clue.

BTW, is there any way I can load emacs editor and do edits on the serial emulator? I tried vi and I had to look back on my cheat sheet.

Thanks guys for your help!

Phuoc_N_Intel
Employee
106 Views

Phuoc_N_Intel
Employee
106 Views

And here is the kit:

root@edison:~# configure_edison --version

159.devkit

Phuoc_N_Intel
Employee
106 Views

I tried the following from another thread and it works now. I would recommend for who can update software changes to update the configure_edison file. It will include all password types to save many people like me time and less frustration.

Thanks for your support.

Hi Trexter,

This does not happen for me, when I enter the Linux console I enter configure_edison –setup. This gives me an option to change the device name, I used edison in this example. Then the system asks me to choose a password for the device and I use an 8 digit password and confirm. Then you have to choose the wifi you wish to connect to, and press the number. Then you must enter the network password you wish to connect to, password must be between 8 and 63 characters. After confirming the password you should then have access to a wireless connection . What version of the image are you using and from where did you download it?

Regards

Sergio

Reply