Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Novice
2,616 Views

Installation error. Integrity fail

I just got the board 2 days ago and I am newly installing the driver.

I got this error which I don't know how to fix.

please see attachment.

27 Replies
Highlighted
Beginner
51 Views

Getting the same error when installing on a new laptop. looks like its something to do with the license rtf file.

to get you up and running

download the individual parts ide you want firmware image and install them as in the user guides

Highlighted
Community Manager
51 Views

Hi InnovatorPrime,

 

 

Following the suggestion from paulbearne, you can install the drivers manually with the following guide: https://software.intel.com/en-us/get-started-edison-windows-32-step2 https://software.intel.com/en-us/get-started-edison-windows-32-step2

 

 

If you are still getting issues when installing the drivers manually, post a screenshot of the error message so we can help you with it.

 

 

Regards,

 

Diego
Highlighted
Novice
51 Views

i got this integrety check error

0 Kudos
Highlighted
Novice
51 Views

hey I tried to I don't get how that flash-tool-lite work

0 Kudos
Highlighted
Novice
51 Views

I did you told still not completely fix.

0 Kudos
Highlighted
Community Manager
51 Views

Hi InnovatorPrime,

 

 

Did you follow the guide I linked above? From your pictures, I see that you are not installing the drivers manually. The driver you have to install is the following: http://downloadmirror.intel.com/24909/eng/IntelEdisonDriverSetup1.2.1.exe http://downloadmirror.intel.com/24909/eng/IntelEdisonDriverSetup1.2.1.exe

 

 

Regarding the Flash Tool Lite, you can download it from the following site: https://software.intel.com/en-us/iot/hardware/edison/downloads https://software.intel.com/en-us/iot/hardware/edison/downloads. Then, follow this guide to install the software: https://software.intel.com/en-us/articles/flash-tool-lite-user-manual https://software.intel.com/en-us/articles/flash-tool-lite-user-manual

 

 

Regards,

 

Diego
0 Kudos
Highlighted
Novice
51 Views

Hey Diego:

The driver was successful but

I got these error when I try to flash the Edison board.

4/06/16 23:20:14.699 INFO : [Port -1] Starting flash ...

04/06/16 23:20:14.699 INFO : [Port -1] Running `Notify` command

04/06/16 23:20:14.745 INFO : Displaying notification during 42000 ms

04/06/16 23:20:14.747 INFO : [Port -1] Command `Notify` succeed

04/06/16 23:20:14.747 INFO : [Port -1] Running `Wait for device with status dnx_fw on port -1` command

04/06/16 23:20:56.748 ERROR : [Port -1] Command `Wait for device with status dnx_fw on port -1` failed

04/06/16 23:20:56.748 ERROR : [Port -1] Flash failed (Command type: Device enumeration)

0 Kudos
Highlighted
Novice
51 Views

Some flash install also fail but with different messages.

04/07/16 00:21:39.955 INFO : [Port 1/1/6] Start flashing the flash configuration with dnx_fw start state for E6AFF6E1E5907B1E73DD135962D0E95E

04/07/16 00:21:39.956 INFO : [Port 1/1/6] Starting flash ...

04/07/16 00:21:39.956 INFO : [Port 1/1/6] Running `Notify` command

04/07/16 00:21:40.304 INFO : Displaying notification during 42000 ms

04/07/16 00:21:40.324 INFO : [Port 1/1/6] Command `Notify` succeed

04/07/16 00:21:40.325 INFO : [Port 1/1/6] Running `Wait for device with status dnx_fw on port 1/1/6` command

04/07/16 00:21:40.325 INFO : [Port 1/1/6] Command `Wait for device with status dnx_fw on port 1/1/6` succeed

04/07/16 00:21:40.325 INFO : [Port 1/1/6] Running `Notify` command

04/07/16 00:21:40.334 INFO : Displaying notification during 5000 ms

04/07/16 00:21:40.335 INFO : [Port 1/1/6] Command `Notify` succeed

04/07/16 00:21:40.335 INFO : [Port 1/1/6] Running `"xfstkFlashTool.exe" "-1" "C:\Users\wenboma\Downloads\iot-devkit-prof-dev-image-edison-20160315\edison_dnx_fwr.bin" "C:\Users\wenboma\Downloads\iot-devkit-prof-dev-image-edison-20160315\edison_ifwi-dbg-00.bin" "C:\Users\wenboma\Downloads\iot-devkit-prof-dev-image-edison-20160315\edison_dnx_osr.bin" "C:\Users\wenboma\Downloads\iot-devkit-prof-dev-image-edison-20160315\u-boot-edison.img" "0x80000007" "none" "none" "0"` command

04/07/16 00:21:40.356 INFO : [Port 1/1/6] Disabling xFSTK Misc DnX

04/07/16 00:21:40.356 INFO : [Port 1/1/6] Disabling xFSTK wipe out ifwi option

04/07/16 00:21:40.356 INFO : [Port 1/1/6] Using xFSTK Solo interface (new API)

04/07/16 00:21:40.356 INFO : [Port 1/1/6] xFSTK Soft Fuse not set

04/07/16 00:21:40.356 INFO : [Port 1/1/6] XFSTK Downloader API 1.8.1

04/07/16 00:21:40.356 INFO : [Port 1/1/6] Copyright (c) 2015 Intel Corporation

04/07/16 00:21:40.356 INFO : [Port 1/1/6] fwdnx -- C:\Users\wenboma\Downloads\iot-devkit-prof-dev-image-edison-20160315\edison_dnx_fwr.bin

04/07/16 00:21:40.356 INFO : [Port 1/1/6] fwimage -- C:\Users\wenboma\Downloads\iot-devkit-prof-dev-image-edison-20160315\edison_ifwi-dbg-00.bin

04/07/16 00:21:40.356 INFO : [Port 1/1/6] osdnx -- C:\Users\wenboma\Downloads\iot-devkit-prof-dev-image-edison-20160315\edison_dnx_osr.bin

04/07/16 00:21:40.356 INFO : [Port 1/1/6] osimage -- C:\Users\wenboma\Downloads\iot-devkit-prof-dev-image-edison-20160315\u-boot-edison.img

04/07/16 00:21:40.356 INFO : [Port 1/1/6] gpflags -- 0x80000007

04/07/16 00:21:40.356 INFO : [Port 1/1/6] softfuse --

04/07/16 00:21:40.366 INFO : [Port 1/1/6] XFSTK-STATUS--Detecting Intel Device - Attempt # 0

04/07/16 00:21:41.496 INFO : [Port 1/1/6] XFSTK-STATUS--Detecting Intel Device - Attempt # 1

04/07/16 00:21:42.626 INFO : [Port 1/1/6] XFSTK-STATUS--Detecting Intel Device - Attempt # 2

04/07/16 00:21:43.756 INFO : [Port 1/1/6] XFSTK-STATUS--Detecting Intel Device - Attempt # 3

04/07/16 00:21:44.386 INFO : [Port 1/1/6] XFSTK-STATUS--Detecting Intel Device - Attempt # 4

04/07/16 00:21:45.517 INFO : [Port 1/1/6] XFSTK-STATUS--Detecting Intel Device - Attempt # 5

04/07/16 00:21:46.647 INFO : [Port 1/1/6] XFSTK-STATUS--Detecting Intel Device - Attempt # 6

04/07/16 00:21:47.777 INFO : [Port 1/1/6] XFSTK-STATUS--Detecting Intel Device - Attempt # 7

04/07/16 00:21:48.407 INFO : [Port 1/1/6] XFSTK-STATUS--Detecting Intel Device - Attempt # 8

04/07/16 00:21:49.537 INFO : [Port 1/1/6] XFSTK-STATUS--Detecting Intel Device - Attempt # 9

04/07/16 00:21:50.667 INFO : [Port 1/1/6] XFSTK-STATUS--Detecting Intel Device - Attempt # 10

04/07/16 00:21:51.797 INFO : [Port 1/1/6] XFSTK-STATUS--Detecting Intel Device - Attempt # 11

04/07/16 00:21:52.427 INFO : [Port 1/1/6] XFSTK-STATUS--Detecting Intel Device - Attempt # 12

04/07/16 00:21:53.557 INFO : [Port 1/1/6] XFSTK-STATUS--Detecting Intel Device - Attempt # 13

04/07/16 00:21:54.687 INFO : [Port 1/1/6] XFSTK-STATUS--Detecting Intel Device - Attempt # 14

04/07/16 00:21:55.817 INFO : [Port 1/1/6] XFSTK-STATUS--Detecting Intel Device - Attempt # 15

04/07/16 00:21:56.447 INFO : [Port 1/...

0 Kudos
Highlighted
Community Manager
51 Views

Hi InnovatorPrime,

 

 

Could you take a screenshot of the Device Manager while the USB port is connected to the PC? I'd like to check the status of the COM port and confirm that the Edison is recognized. If the board is recognized, you should see the Edison drive in Windows Explorer when the USB cable is connected to the PC.

 

 

Additionally, I recommend you to try using an alternative method to flash the Edison. This method uses a script called flashall. The process is described in the following document: /docs/DOC-25154 https://communities.intel.com/docs/DOC-25154. If there is an error during the process, please take a screenshot so I can check the error message.

 

 

Regards,

 

Diego
0 Kudos
Highlighted
Novice
51 Views

I do see the COM port

0 Kudos
Highlighted
Novice
51 Views

C:\Users\wenboma\Downloads\iot-devkit-prof-dev-image-edison-20160315>flashall.ba

t

Using U-boot target: edison-blankrndis

Now waiting for dfu device 8087:0a99

Please plug and reboot the board

Dfu device not found Timeout

Did you plug and reboot your board?

If yes, please try a recovery by calling this script with the --recovery option

i tried the instruction but they don't recognize the board it seems. it time out

0 Kudos
Highlighted
Community Manager
51 Views

Hi InnovatorPrime,

 

 

Did you reboot the board? When running the flashall script, you have to unplug the power source and then plug it again. The flashall script should recognize the board during the booting process. Also, make sure you have copied the dfu-util.exe file in the same directory where the image files are located, otherwise you will get an error.

 

 

Regards,

 

Diego
0 Kudos
Highlighted
Novice
51 Views

Hey Diego:

The flashell.sh worked. I have to reset by flipping the USB switch unplugging the power was not enough. What is my next step?

0 Kudos
Highlighted
Novice
51 Views

The Intel Edison USB Composite Device COM Port is missing how do i fix that?

 

0 Kudos
Highlighted
Community Manager
51 Views

Hi InnovatorPrime ,

 

 

If you are on Windows, you have to use the flashall.bat file, not the flashall.sh file. Could you please take a screenshot of the flashing process status? I'd like to check what the outcome is.

 

 

In order to check if you have flashed the Edison successfully, run the following command in the Edison's console: cat /etc/version. The following guide will show you how to access the Edison's console: https://software.intel.com/en-us/get-started-edison-windows-32-step5 https://software.intel.com/en-us/get-started-edison-windows-32-step5.

 

 

Additionally, make sure you have installed the drivers required for the USB and Serial ports: https://software.intel.com/en-us/get-started-edison-windows-32-step2 https://software.intel.com/en-us/get-started-edison-windows-32-step2. You should have them installed by now, but run the installers again just to be sure. Please provide a screenshot of the installation message of the USB driver.

 

 

Regards,

 

Diego
0 Kudos
Highlighted
Novice
51 Views

Hey Diego:

here is the CMD when i installed the flashall.bat

I installed the USB driver already. I don't know if it worked.

0 Kudos
Highlighted
Community Manager
51 Views

Hi InnovatorPrime,

 

 

According to the screenshot, it seems that the flashing process ended successfully. In order to check if the Edison was flashed with the latest image, run the following command in the Edison's console: cat /etc/version.

 

 

To access the Edison's console, you have to use a software called PuTTY. The process of accessing the Edison's console is described in the following guide: https://software.intel.com/en-us/get-started-edison-windows-32-step5 https://software.intel.com/en-us/get-started-edison-windows-32-step5

 

 

Please take a screenshot of the Edison's console when running the command above.

 

 

Regards,

 

Diego
0 Kudos
Highlighted
Novice
51 Views

The serial connection didn't work. No asking for Login just blank. I use COM7.

I also installed the usb driver.

0 Kudos
Highlighted
Community Manager
51 Views

Hi InnovatorPrime,

 

 

That's weird, considering the fact that the latest image was flashed successfully. Could you confirm if you are still seeing the "Intel Edison Virtual Com Port" and "USB Serial Port" ports only? You should also see another COM port labeled as "Intel Edison USB Composite Device".

 

 

Anyhow, if you have installed the drivers and flashed the image, but you are not able to access the Edison's console, I recommend you to contact the place of purchase and explain the issue to them. If I'm not mistaken you got the module recently so they should help you if you are still under their warranty period.

 

 

Other option, in case the place of purchase don't contact you back, is to open a warranty ticket using the following form: https://customercare.intel.com/?lang=en-US https://customercare.intel.com/?lang=en-US. The Warranty Team will contact you as soon as they receive your ticket, however, I recommend you to contact the place of purchase first since you got the board recently.

 

 

Regards,

 

Diego

 

0 Kudos