Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
99 Views

Intel CSI Tool with Galileo Gen 2

I am working on Galileo Gen2 for several weeks for installing CSI tool.

I followed this link http://dhalperi.github.io/linux-80211n-csitool/installation.html Linux 802.11n CSI Tool — Installation Instructions

I tried to install it on both debian system for Galileo Gen2(https://sourceforge.net/p/galileodebian/wiki/DebianOnGalileo/ the link I followed to install debian on Galileo Gen2 ) and Linux galileo 3.8.7-yocto-standard .

However, I find that I need to install linux-headers which csi tool needs to recompile and change some kernel modules like iwlwifi as the following command shows.

make -C /lib/modules/$(uname -r)/build M=$(pwd)/drivers/net/wireless/iwlwifi modules

So,I tried to install linux-headers for the Linux galileo 3.8.7-yocto-standard kernel.  However I can't find anything helpful for me to install the corresponding linux-headers.

Then I tried to compile kernel using the source codes https://github.com/dhalperi/linux-80211n-csitool directly so that the kernel modules are what csi tool needs. I builded the kernel from 3.8.0 to 4.1.0 successfully using the original .config file  from 3.8.7-yocto-standard kernel. The correlative kernel files and kernel headers I need are also generated. 

I think the system boot configuration file is from the grub.conf from /boot/grub/grub.conf on the SD card first partition .The partial content of this file is on the following.

title Custom Quark Kernel with Debian Wheezy
root (hd0,3)
kernel /boot/vmlinuz-3.8.7+ root=/dev/mmcblk0p4 3 console=ttyQRK1,115200n8 earlycon=uart8250,mmio32,$EARLY_CON_ADDR_REPLACE,115200n8 vmalloc=3844M reboot=efi,warm apic=debug rw LABEL=boot debugshell=5
initrd /boot/initrd.img-3.8.7+

I changed the part I marked in red in the grub.conf file from 3.8.7+ to 3.8.0( because vmlinuz-3.8.0 and initrd.img-3.8.0 are generated on the same place) 

But it failed to load the 3.8.0 kernel after I changed the grub.conf file. it just stopped on 

[Linux-EFI, setup=0x10c1, size=0x21d710]
[Initrd, addr=0xd9b1000, size=0x43ff38]

So, there are two questions I want to ask

First, how can I install the yocto 3.8.7 kernel headers for csi tool installation?

Second, how can I change the kernel I compiled myself on Linux galileo 3.8.7-yocto-standard or debian for galileo ?

I upload some screen shots from booting the system and the grub.7z file containing grub.conf

I would appreciate it if you would help me solve these problems. Thanks a lot 

Labels (1)
Tags (1)
0 Kudos
0 Replies