Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Novice
2,658 Views

Intel Compute Stick can't wake from sleep with Microsoft All-in-one keyboard

Hi there community. Just signed up and it is good to be here.

I am facing a problem with my compute stick. This is my 2nd stick, it came preloaded with Windows 10 and it is the 32GB model.

I can't seem to wake it up after going to sleep with my keyboard (Microsoft All-in-one).I even updated the BIOS but no luck. I've set it (the BIOS) to "Always On".

In the device manager I've set all possible devices to "Allow this device to wake up the computer" but to no avail.

Any ideas?

0 Kudos
16 Replies
Highlighted
Honored Contributor II
118 Views

Hello ManoLee,

Thank you for joining the Intel communities.

I'm sorry to hear that you have problems with the Intel® compute stick.

Do you have the keyboard and mouse connected via Bluetooth or wireless?

Please try installing the latest https://downloadcenter.intel.com/download/24816/Graphics-Intel-HD-Graphics-driver-for-Intel-Compute-... Intel® HD Graphics driver

Make sure Windows is up to date.

Please let me know if that can help you.

Thank you!

0 Kudos
Highlighted
Novice
118 Views

Hi ivanu,

All updates for Windows are already installed and I have already downloaded and installed the latest graphics software. One strange thing though is that the power management tab in the HD intel control panel has no settings to change.Any ideas?

0 Kudos
Highlighted
Employee
118 Views

Hi ManoLee,

Could you please post a picture where you're seeing the power management tab?

Do you have the keyboard and mouse connected via Bluetooth or wireless?

0 Kudos
Highlighted
Novice
118 Views

The keyboard is connected through wireless.

Here is a snapshot of the power management tab of Intel HD graphics control panelhttps://www.dropbox.com/s/y1un0c3cp74aacb/Capture.PNG?dl=0 https://www.dropbox.com/s/y1un0c3cp74aacb/Capture.PNG?dl=

0 Kudos
Highlighted
Novice
118 Views

The problem persists. I think it is the keyboard. Microsoft is not answering. Any other suggestions from your side?

0 Kudos
Highlighted
Honored Contributor II
118 Views

In this case, the best way to know if a keyboard is the problem is to test it with another one, at this point I recommend waiting for a new BIOS version to be release or new graphics driver.

0 Kudos
Highlighted
Beginner
118 Views

I've had similar issues with an SMK-link all in one handheld. Wired keyboards and other standard wireless mice were able to wake it though.

For my issues, I tried disabling sleep mode, because when your display is turned off for a long period of time, your compute stick will put itself to sleep. I'm pasting a reply from another Intel user for changing a registry value:

Open regedit.exe, go to HKLM\System\CurrentControlSet\Control\Power\ and set the value CsEnabled from 1 to 0.

 

It worked for me.

 

I've tried this overnight once, and it appears to have worked. The stick did not go to sleep.

 

0 Kudos
Highlighted
Honored Contributor II
118 Views

Thank you for the information you have shared with us realeyes.

0 Kudos
Highlighted
Novice
118 Views

The thing is that I want my stick to go to sleep. I don't want it to be on all the time.

I have already returned the keyboard and I am waiting for a replacement. Will post back if the problem is resolved with the new Microsoft All in one keyboard.

0 Kudos
Highlighted
Honored Contributor II
118 Views

I understand and I will appreciate if you could post back if the problem is resolved with the new Microsoft All in one keyboard.

0 Kudos
Highlighted
Novice
118 Views

I am convinced that the problem is with the stick and not with the keyboard. I got a new one today and the situation remains the same. I even tried with another keyboard and the same happens. After the Intel Compute Stick goes into deep sleep it can't wake up no matter what. All keyboards are set to "Allow this device to wake the computer" in Device Manager. Should I return it for a new one? What are you suggesting? Waiting for a new BIOS is lost time I think since we can't have an ETA from Intel, right?

0 Kudos
Highlighted
Honored Contributor II
118 Views

Hi,

I tried this configuration and I did not have any problems waking the Intel® Compute Stick from sleep mode.

I tested the unit with a Logitech wireless keyboard/mouse and the receiver that will be installed in USB port.

I have the latest BIOS installed and updates, also I made sure the option in the device manager to allow this device to wake the computer is checked.

Access device manager > Right click on the keyboard device>Power management tab and check allow this device to wake my computer.

I did not have any problems; if you replace the keyboard and tested with different keyboard and the problem persists you can submit a warranty replacement for the unit at the following link:

http://www.intel.com/p/en_US/support/contactsupport http://www.intel.com/p/en_US/support/contactsupport

0 Kudos
Highlighted
Beginner
118 Views

Hello I'm having an issue where my unit keep going into sleep mode even though I have disabled sleep mode in power setting. I am running it as a public display, it it possible to completely disable sleep mode?

0 Kudos
Highlighted
Honored Contributor II
118 Views

I'm not sure how you set the power options, but I set them up as it shows in the pictures below and I don't see any problems.

0 Kudos
Highlighted
New Contributor I
118 Views

Bdcoto. Take a look at this similar question.

Hope this helps

0 Kudos
Highlighted
Honored Contributor II
118 Views

Thank you TerrySanderson for the information you have kindly provided.

Regards!

Ivan

0 Kudos