Showing results for 
Search instead for 
Did you mean: 

Intel Compute Stick "A bootable device has not been detected"

I am trying to install Elementay OS 0.3.2 stable version on my compute stick but when i connect the usb to the single female usb adapted or the stick containing the iso file written to it using Rufus 2.6 I get this error: "A bootable device has not been detected". I can boot to Windows normaly and I have tried to use other programs and other usbs but nothing. I run UEFI and my power mode is Balanced. I would really apreciate it if someone could help me.

0 Kudos
1 Reply
Honored Contributor II

Hello KomninosK,

Thank you for joining the Intel communities.

Do you have the latest BIOS version?

Update the Intel® Compute Stick BIOS; please download the latest BIOS version for this unit here: Download BIOS Update [FCBYT10H.86A]

In this case I recommend doing a BIOS recovery and you can follow the steps at: F7 BIOS Update Instructions for Intel® Compute Stick

You can try with this BIOS update and if you are not able to access Windows at all you can try resetting your system to default after the bios update is done.

Here are the steps:

  1. Remove any SD card, if installed.
  2. Press F8 when you see this prompt during boot: F8 to Activate Windows 8.1* Recovery Mode.
  3. 3. Select Troubleshoot.
  4. Select Reset your PC, then select Next.
  5. Select just remove my files.
  6. Select Reset to start the restore process.

After all that is done try installing the operating system you want but please bear in mind that if an operating system other than the one that comes with it is installed from scratch the warranty will be void, also the OS you would like to install has not been validated by Intel, you can see the operating system supported for this unit at the following link: Intel® Compute Stick Supported Operating Systems

Best regards,