Intel® Makers
Intel® Edison, Intel® Joule™, Intel® Curie™, Intel® Galileo
Welcome - This is a Peer-to-Peer Forum only. Intel has discontinued these products but you may find support from other customers on this Forum
9877 Discussions

Intel Edison Flashing Image error... Drive not displaying....


Hii guys,

I got one Intel Edison with Arduino board with it... Last day I tried to flash new linux image that was 2.1 Yocto with normal extracting and then reboot ota to flash the image on it. But the problem started at extracting. The image zip file of 2.1 Yocto image was 227 MB ans after extraction it increased to 900 MB. But the Intel Edison drive was showing only 768 MB, so also when I tried extract it, it stopped with error disk full as obvious. So I tried to flash it with flash tool. I got phone flash tool sounds little weird with a word phone in it. But I saw some tuts with same gui so I considered it is same. So I selected the .json file and started flashing. After it, it showed like some downloading, but I already had the full image, I kept it as it is. It was seems like downloading something with same as my Internet speed so I considered it is downloading. To download that it crossed 20 minutes (1200 seconds) and error time out and it halted. I tried with other USB port but with same error. Now when I connect my edison to my Windows 8.1 64 bit pc, I can hear the connection sound several times but I didn't see edison drive? Now I am confused what to do.. Plz help me...


2 Replies


Did the process with the Flash tool lite ended? After you receive a notification that the process is complete you'll see a LED in the board flashing, it means the board is rebooting. After the reboot is complete you should have new image flashed. The un compressed image is about 900MB.

Can you show the error of the Flash Tool Lite? How are you powering the Edison board? Can you try using another USB cable? Make sure to connect a power supply along with the USB cable after pressing the "Start to flash" button. What OS are you using on your computer?




Thanks for the reply and sorry for my late reply.

Actually I saw in a video that we have to extract that in that edison drive of 768 MB and then command reboot ota to flash it. But I saw the size of the new 2.1 Yocto image is 900 MB and the Edison's drive is 768 MB, then how can I flash it? So I search and got that we also can flash it with that flash tool. So I saw some tutorials and posts on it about how to flash. So I just started flashing by selecting the .json file and flashing started and reach 84% without any error and then it started downloading its necessary data and when it came to downloading rootfs, which is considerably huge, it got more time than 20 mins to download because of my internet speed and flashtool aborted the flash after 400~500 MB download with the error time out (1200 sec). There was nothing other problem other than downloading that huge files taking more than limit time. I also tried this on Linux but the same problem occurred. Because of that failed flash I could not able to see my Edison drive. Then I saw some tutorials to how to reflash it with flashall batch script. It started and completed with all downloading and flashing without any error and it flashed successfully and now I can see my Edison drive with new image flashed on it.