Community
cancel
Showing results for 
Search instead for 
Did you mean: 
MAlde3
Beginner
1,718 Views

Intel Edison Virtual COM Port is not available

Hello,

I have a problem with my Windows 8.1 laptop. When I connect an Intel Edison to it, Virtual Com Port does not appear. Thus, I can not program Edison using Arduino IDE.

I uninstalled DnX USB Driver and Intel Edison Device USB Driver. Then, reinstalled it using intel_edison_setup_win_v2016.2.007.exe

I tried it several Edisons, and it does not recognize any of them. And these same Edisons work with another laptop.

I can program Edison using Intel XDK and Intel System Studio IoT Edition.

What is the problem?

0 Kudos
8 Replies
idata
Community Manager
96 Views

Hi mstfldmr,

 

 

We'll try to help you solve this issue. We would like to have some more information and provide some suggestions, thanks in advance for your response.
  1. You mentioned that the Edisons are working fine in a different computer, what OS do you have in it?
  2. Make sure to test with different USB cables and USB ports in your computer.
  3. Use your laptop's external power supply. You might get some issues by working only with the internal battery of the laptop.
  4. Power the Edison with the external power supply to avoid any current issue (lack of current).
Let us know if you get different results.

 

 

Regards,

 

-Pablo
idata
Community Manager
96 Views

Hi mstfldmr,

 

 

I'm wondering if you've been able to try our suggestions. We also asked some questions that we would like you to answer in order to better assist you. If you're still having this issue, don't hesitate to contact us.

 

 

Regards,

 

-Pablo
MAlde3
Beginner
96 Views

Hello Pablo,

I tried your suggestions, the result is the same.

This laptop is Windows 8.1, the other laptop is Windows 7.

idata
Community Manager
96 Views

Hi mstfldmr,

 

 

I'm sorry to know that didn't work.

 

Now, I'm wondering if you have some kind of Firewall or some kind of Security configuration in your Windows 8.1 laptop that might be causing the issue. Did you make that this is not the case.

 

Also, could you please try flashing one of your Edison boards? Just to check if there's some change. You can check the instructions here: /docs/DOC-25154 https://communities.intel.com/docs/DOC-25154.

 

Let us know how this goes.

 

 

Regards,

 

-Pablo
idata
Community Manager
96 Views

Hi mstfldmr

 

I hope you're doing well. I'm wondering if you have been able to check our reply, and if flashing the Edison solved the issue.

Regards,

 

-Pablo
Mustafa_A_Intel
Employee
96 Views

Hi Pablo,

I flashed them again. The problem remains

I believe that the problem is not about the Edisons, but with my laptop. Since it's a company laptop, I can not turn off the firewall or the antivirus (McAfee). How can I see what hinders it ?

idata
Community Manager
96 Views

Hi Mustafa,

 

 

Unfortunately, I don't have any specific method to know what could be causing the issue. However, my recommendation would be to contact your company's IT department and ask them if there's anything that could be done to your laptop in order to make the Edison work.

 

Besides from that, my only suggestions would be to try running the manual process. Check the instructions in this link https://software.intel.com/en-us/get-started-edison-windows-32 https://software.intel.com/en-us/get-started-edison-windows-32. Basically, what you'll be doing is installing the USB drivers and the FTDI drivers without using the Run Setup Tool.

 

 

Regards,

 

-Pablo
idata
Community Manager
96 Views

Hi Mustafa,

 

 

I'm wondering if you've been able to get a solution from your company's IT department or if you tried to run our latest suggestion about installing the drivers manually. Let us know if there's any updates on this case.

 

 

Regards,

 

-Pablo
Reply