Community
cancel
Showing results for 
Search instead for 
Did you mean: 
MMasa3
Novice
2,286 Views

Intel Edison Virtual COM Port not Appear

Hi! I have a problem with my Intel Edison Arduino Breakout board. Version 159 dev kit.

When my edison starts, on my computer not appear Intel Edison Virtual COM Port and Intel Edison Composite Device. I checked on another computer but result is similar, I have only USB Serial Port. Two USB connected, black switch towards two mini-USB ports, I changed many USB cables and etc.

I have noticed when edison boots is a error in Kernel Modules. In Putty Edison works well, but I can't download any Arduino sketch to Edison board because no COM-ports. Does this problem is hardware? I put Edison module on another Arduino breakout board, but result is the same. Who can help me?

UPDATED. Suppose now I have a brick) Edison can't boot after this guide( http://alextgalileo.altervista.org/blog/install-kernel-from-repo-onto-edison-official-image/ How to install a kernel from my repo onto Edison with the official image

run do_ota is not helpful. One more problem)

7 Replies
idata
Community Manager
210 Views

Hi,

 

 

Your issue may be related to not having the proper drivers installed. First, make sure you've completed the assembling guide, are powering the board using an external power supply and can see the Edison as a drive in your computer. https://software.intel.com/en-us/get-started-edison-windows-32-step1 https://software.intel.com/en-us/get-started-edison-windows-32-step1 .

 

 

Now, proceed to the installation of drivers following the guide here https://software.intel.com/en-us/get-started-edison-windows-32-step2 https://software.intel.com/en-us/get-started-edison-windows-32-step2 . Consider that at some point of this process, windows will ask you to install the drivers automatically. Ignore this request and install the drivers manually as stated in the guide. At the end of the guide there's a "Confirm installation of Intel® Edison drivers". Make sure you see something similar to the picture in your device manager.

 

 

About the error to start kernel modules, I'd suggest you to reflash your Edison with a new image but don't use the run do_ota method. The recommended method is the Flash Tool Lite. Follow the instructions from here to flash your board https://software.intel.com/en-us/articles/flash-tool-lite-user-manual https://software.intel.com/en-us/articles/flash-tool-lite-user-manual .

 

 

After re flashing, try installing the drivers as described above. What Arduino IDE version have you installed, have you installed the Edison board through the Boards manager?

 

 

Sergio

 

MMasa3
Novice
210 Views

Thanks for the reply, but I have all Intel Edison drivers installed. I have 5 Edison boards and all boards work well (all COM-ports appear on both computers), but this Edison is wrong This is Error for today. Edison can't boot, no Virtual COM-port and no Intel Edison Composite device in Device manager.

idata
Community Manager
210 Views

Take a look at this /docs/DOC-25154 https://communities.intel.com/docs/DOC-25154 . This is a guide for running the flashall script. Try with this approach. If you receive any errors, please post a screenshot.

 

 

Let us know your results.

 

 

Sergio

 

idata
Community Manager
210 Views

Were you able to get your Edison recognized, did you try the flashall method we recommended?

 

 

Sergio

 

MMasa3
Novice
210 Views

I'm not able to get Edison recognized. I reinstall drivers on PC, but situation is the same. Only one COM-port -USB Serial Port.

idata
Community Manager
210 Views

What were the results of doing the flashall script? Was it unresponsive, did you see any error messages? Please be as descriptive as possible when describing the results of running the flashall script.

 

 

Sergio

 

idata
Community Manager
210 Views

Try the install the phone flash flash tool and the dfu-util postet in this thread:

after that you should be able to use the flashall.bat and the edison should be detected

Flo1991

Reply