Intel® Makers
Intel® Edison, Intel® Joule™, Intel® Curie™, Intel® Galileo
Announcements
Welcome - This is a Peer-to-Peer Forum only. Intel has discontinued these products but you may find support from other customers on this Forum
9881 Discussions

Intel Edison and Arduino IDE for intelligent vehicle

tprab
Novice
983 Views

I am working with intel Arduino IDE and developer board is Intel Edison ,

The Idea of the project is to develop a Intelligent vehicle using Edison board,

 

here I had a problem with this, That was am actually using grove things like LCD display, buzzer and ultrasonic sensor, The problem here is the moment I remove USB cable from Edison Board it is not working, It means I was not able to use the board on vehicle because it always need USB cable.

Can any one help me in resolving this issue, but remember that i would like to use Arduino IDE,

 

If it is not possible with Arduino IDE then help me doing with nodejs or any other thing.
1 Solution
idata
Community Manager
115 Views

Hi CommonMan,

 

 

Thank you for contacting us.

 

 

The problem you're experiencing, where the Arduino sketch stops after the USB cable is disconnected, is a known issue with newer images. This issue, however, didn't exist on previous images such as "Release 2.1". I'd suggest you to reflash your Edison to this image and continue developing your project. The link to download Release 2.1 is https://downloadcenter.intel.com/download/24910 https://downloadcenter.intel.com/download/24910 .

 

 

We're aware this functionality is very useful to the community and we've already reported this to the proper team. You can see a similar discussion here: /thread/99018 https://communities.intel.com/thread/99018

 

 

Let us know if this is what you were looking for.

 

 

Regards,

 

-Sergio A

 

View solution in original post

1 Reply
idata
Community Manager
116 Views

Hi CommonMan,

 

 

Thank you for contacting us.

 

 

The problem you're experiencing, where the Arduino sketch stops after the USB cable is disconnected, is a known issue with newer images. This issue, however, didn't exist on previous images such as "Release 2.1". I'd suggest you to reflash your Edison to this image and continue developing your project. The link to download Release 2.1 is https://downloadcenter.intel.com/download/24910 https://downloadcenter.intel.com/download/24910 .

 

 

We're aware this functionality is very useful to the community and we've already reported this to the proper team. You can see a similar discussion here: /thread/99018 https://communities.intel.com/thread/99018

 

 

Let us know if this is what you were looking for.

 

 

Regards,

 

-Sergio A

 

Reply