Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Novice
1,606 Views

Intel Edison and SparkFun Base Block Boot

Hello everybody,

I'm having a weird problem using intel edison and sparkfun base block, i plugged it into my computer, but the driver installed was the default, so the only thing that I could see in Putty was:

******************************

PSH KERNEL VERSION: b0182727

WR: 20104000

******************************

SCU IPC: 0x800000d0 0xfffce92c

PSH miaHOB version: TNG.B0.VVBD.0000000c

microkernel built 23:15:13 Apr 24 2014

******* PSH loader *******

PCM page cache size = 192 KB

Cache Constraint = 0 Pages

Arming IPC driver ..

Adding page store pool ..

PagestoreAddr(IMR Start Address) = 0x04899000

pageStoreSize(IMR Size) = 0x00080000

*** Ready to receive application ***

 

and this message eas show many times, so I tried to re-install the driver of the Edison Console, but all the times I did it my computer failed and restarted, what should I do?

 

5 Replies
Highlighted
Employee
20 Views

Hello WagnerSodre,

I recommend you to re-flash your Edison module using the Flash Tool Lite. You can download it from the following site, under the Flash Tool Lite section: https://software.intel.com/en-us/iot/hardware/edison/downloads IoT - Intel® Edison Board Download | Intel® Developer Zone. Additionally, a user's manual for the Flash Tool Lite can be checked in the following site: https://software.intel.com/en-us/articles/flash-tool-lite-user-manual IoT - Flash Tool Lite User Manual | Intel® Developer Zone

The drivers for the Edison are in the http://https//software.intel.com/en-us/iot/hardware/edison/downloads Software Downloads too. I recommend you to try installing the Windows Standalone Driver before re-flashing the Edison.

Regards,

Diego.

Highlighted
Novice
20 Views

Hello DiegoV_Intel,

I tried it, but it didn't work. Errors happened all the times, exactly at 7%. It showed to me that 0/1 or 0/2 ports.

Example:

10/26/15 15:41:53.979 INFO : [Port 0/2] Start flashing the flash configuration with dnx_fw start state for

10/26/15 15:41:53.981 ERROR : Automatic reboot is not supported on this device, please reboot the device manually

10/26/15 15:41:53.982 INFO : [Port 0/2] Starting flash ...

10/26/15 15:41:53.982 INFO : [Port 0/2] Running `Notify` command

10/26/15 15:41:54.852 INFO : Displaying notification during 42000 ms

10/26/15 15:41:54.902 INFO : [Port 0/2] Command `Notify` succeed

10/26/15 15:41:54.902 INFO : [Port 0/2] Running `Wait for device with status dnx_fw on port 0/2` command

10/26/15 15:42:36.903 ERROR : [Port 0/2] Command `Wait for device with status dnx_fw on port 0/2` failed

10/26/15 15:42:36.903 ERROR : [Port 0/2] Flash failed (Command type: Device enumeration)

Thanks for the help anyway,

WagnerSodre.

Highlighted
Employee
20 Views

Hello WagnerSodre,

There is another alternative way to re-flash the Edison module. This method uses the flashall script. A step-by-step guide is available in the following document:

Additionally, make sure you are connecting the Edison to a USB 2.0 port. There are issues reported when the board is connected to a USB 3.0 port.

If the flashall script method doesn't work, I suggest you to contact SparkFun (I suppose it is place where you purchased the board from). If you got the board recently, you should claim the warranty because the board is not recoverable through the flashing methods available. However, make sure to use a USB 2.0 port. In the following thread, the user wasn't able to flash the Edison module because of the USB port used:

Regards,

Diego.

0 Kudos
Highlighted
Honored Contributor II
20 Views

I'd suggest you to try another USB port first - I've seen very similar symptoms myself. It was not USB 3.0 per se, but USB 3.0 charging port (the one with a lightning sign), which caused troubles in my case.

0 Kudos
Novice
20 Views

Thanks for the help, It solved my problem. My Intel Edson is now working

0 Kudos