Showing results for 
Search instead for 
Did you mean: 

Intel Edison flash problem - "./ command not found"

Hey guys, I tried first time to flash Yocto images on my Intel Edison (arduino), but something I've done wrong. I am using OS X El Capitana. Firstly I tried to use Phone Flash Tool but it didn't work. Secondly I found solution with manual flash and according to the steps I deleted data from my Edison. Later I realized that new version of Yocto its to big to upload on Edison manually and you need to use… Intel Phone Flash Tool… which is not working for me. I gone a little bit deeper and found solution below:

On Mac

1. Open a new Terminal session and run the following commands:

1. ruby -e "$(curl -fsSL"

2. brew install dfu-util coreutils gnu-getopt

2. Go to the folder where the "Yocto* Complete image" files were extracted and run:

1. ./

3. Plug the board to the PC and reboot the board when the process asks for it. Then wait for the process to be completed.

I pass first step without problems but when I try to use ./ command in path where I extract the Yocto image I receive "sudo: ./ command not found". I can't find any additional information about this issue. I am afraid that I broke my software when I log in to the Edison and ask him about firmware he tell me "Could not determine firmware version information. Quitting. none"

Any ideas where is the problem ? I stuck on it for last two days.

0 Kudos
4 Replies

Hi ruter999,

Please try with the previous image, release 3.0,, this is just to make sure everything is alright with your board. I would like to run some tests myself using OSX and the latest image. Please let us know if flashing the board with image 3.0 is working for you.




Dear PabloM, &# 8232;

Thanks for your prompt answer, I have good (?) news from the board. I download latest Yocot image a few days ago but since that time I didn't have occasion to set up my fresh-new Edison. I started just 2 days ago with image 3.0 - iot-devkit-prof-dev-image-edison-20160315 - which I downloaded in advance, before I flew to Ethiopia (internet service in here is provided by the turtles). It's mean that whole my story described above refers to release 3.0. &# 8232;

However, you turned my attention to the latest software - iot-devkit-prof-dev-image-edison-20160606 - I left my mac for few hours to download unbelievable amount of 299 MB data, go trough the process again and .... finally SUCCEEDED !&# 8232;

But let me underline that I'm still not sure whether all is fine:

  • ver. 2016 03 15 is not working and I don't know the reason
  • after software installation my mac stop to recognise Edison. I receive "The disk you inserted was not readable by this computer". I attached disk utility information
  • he still don't recognise firmware

Anyway I uploaded first "LED blink" software on Arduino and it is blinking so I trust that starting setup is finally done well ?

Community Manager

Hi ruter999,



If you were able to make the Blink sketch work then I believe your current Yocto image and board are working correctly. To run any Arduino sketch it is necessary for the OS to run the Linux service in charge of performing this task, so I would discard any problem with the image. I did some tests and was able to flash the 3.0 image in my OSX system, so I'm guessing that it has something to do with a corrupt image (downloaded file) or with your specific OSX distribution. Do you have any other computer where you can test this?






Dear Pablo,

Sorry for the late answer. Unfortunately I don't have any other. I also guess that the problem was in software image which I downloaded. Anyway up to now its is working fine.

Thanks and best regards !