Intel® Makers
Intel® Edison, Intel® Joule™, Intel® Curie™, Intel® Galileo
Announcements
Welcome - This is a Peer-to-Peer Forum only. Intel has discontinued these products but you may find support from other customers on this Forum
9868 Discussions

IoTkitSimpleExample and IoTkitRegisterExample Application issue

xzhan35
New Contributor I
1,573 Views

Hi all,

I tested this example,but it can't receive any data inDash board.

1. iotkit-admin test command is ok.

2. iotkit-admin activat code command is ok.

3. I create a device in cloud with my device id.

4. then I run the command: systemctl start iotkit-agent

5. I adjust my IP address "IOTKIT_IP" in IoTkit.h.

6. I run arduino app IoTkitRegisterExample with my activate key.

7. then run IoTkitSimple Example.

8. I 'm sure that the IoTkitSimple app is download into edison board, and running.

Finally, there is nothing in Dash board.

so is there something I do wrong?

Please help me out.

 

thanks,

xiaoqing

 

0 Kudos
6 Replies
Pedro_M_Intel
Employee
132 Views

Hello connor.zhang,

I found the https://software.intel.com/sites/default/files/managed/2a/e9/Intel-DeveKit-Tutorial-Guide.pdf?_ga=1.... Intel® Galileo Development Kit for IoT Tutorial Guide, I think you can use the ideas and adjust them to Edison, maybe you find it helpful.

However if you are able to make it work I invite you to post your results in the community.

If you have any more doubts don't hesitate to ask.

Regards,

Peter

xzhan35
New Contributor I
132 Views

Hi Peter,

Thank you very much, It's work, but this example is just in edison arduino board, dose it have a eclipse example project about iotkit ? and which libraries or files should I add to my eclipse project for communicate to cloud.

Pedro_M_Intel
Employee
132 Views

Hello connor.zhang,

You can take a look to the next post they talk about implementing Eclipse, maybe you can find it helpful.

Regards,

Peter

Carlos_M_Intel
Employee
132 Views

Hi connor.zhang;

Were you able to receive data in the DashBoard?

Regards;

CMata

xzhan35
New Contributor I
132 Views

Hi CMata,

It can receive data in the DashBoard, but it is not stable and appear that:

root@edison:~# iotkit-admin test

2014-11-26T02:44:25.428Z - info: Trying to connect to host ...

2014-11-26T02:44:31.565Z - error: Data Submission Error code=ENOTFOUND, errno=ENOTFOUND, syscall=getaddrinfo

2014-11-26T02:44:31.573Z - error: Connection failed to dashboard.us.enableiot.com

so , how can I improve the stability ?.

AT9
Honored Contributor II
132 Views

That looks like a DNS problem in your setup more than anything else IMHO. The error looks like a name resolution one and as such it's unlikely to be related to anything like iotkit libraries, it's rather something wrong with your network connection or DNS server. Try running some name resolution command in a loop to see how frequently it fails, that may give you some clues to the root cause.

Reply