Community
cancel
Showing results for 
Search instead for 
Did you mean: 
idata
Community Manager
950 Views

Issue with MQTT with Paho on Intel Galileo

Jump to solution

I was starting to feel sorry for my 2 Intel Galileo boards as they haven't seen much action for a while so I decided to build some example scripts for my Python module that allows devices to connect to my developer platform via Paho. The package has the required certificate included that is required to connect to the MQTT broker (and works with no issues on Raspberry Pi) but I am getting the following error, does anyone have any ideas how to resolve this issue, I finally have some plans for the two boards and hit a road block straight away.

python IntelGalileoDevice.py

Traceback (most recent call last):

File "IntelGalileoDevice.py", line 55, in

JumpWayPythonMQTTDeviceConnection.connectToDevice()

File "/usr/lib/python2.7/site-packages/techbubbleiotjumpwaymqtt/device.py", line 58, in connectToDevice

self.mqttClient.connect(self.mqttHost,self.mqttPort,10)

File "/usr/lib/python2.7/site-packages/paho/mqtt/client.py", line 612, in connect

return self.reconnect()

File "/usr/lib/python2.7/site-packages/paho/mqtt/client.py", line 747, in reconnect

ciphers=self._tls_ciphers)

File "/usr/lib/python2.7/ssl.py", line 381, in wrap_socket

ciphers=ciphers)

File "/usr/lib/python2.7/ssl.py", line 143, in __init__

self.do_handshake()

File "/usr/lib/python2.7/ssl.py", line 305, in do_handshake

self._sslobj.do_handshake()

ssl.SSLError: [Errno 1] _ssl.c:506: error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed

The module can be found here:

https://github.com/AdamMiltonBarker/TechBubble-Iot-JumpWay-Python-MQTT GitHub - AdamMiltonBarker/TechBubble-Iot-JumpWay-Python-MQTT: TechBubble IoT JumpWay Python MQTT Module


Accepted Solutions
idata
Community Manager
53 Views

Solved this it was the time settings had to issue:

date mmddhhmmYY

View solution in original post

1 Reply
idata
Community Manager
54 Views

Solved this it was the time settings had to issue:

date mmddhhmmYY

View solution in original post