Community
cancel
Showing results for 
Search instead for 
Did you mean: 
idata
Community Manager
1,755 Views

Issues with intel galileo iotkit-agent test

I've been trying to connect to intel iot analytics with my galileo gen 2 and I was following this tutorial

https://software.intel.com/en-us/intel-iot-platforms-getting-started-cloud-analytics# testing-network-connectivity https://software.intel.com/en-us/intel-iot-platforms-getting-started-cloud-analytics# testing-network-connectivity

I got to the test connection section basically got this error message

root@galileo:~# iotkit-admin test

2016-01-11T13:08:28.328Z - info: Trying to connect to host ...

2016-01-11T13:08:28.956Z - error: Data Submission Error code=ECONNRESET

2016-01-11T13:08:28.980Z - error: Connection failed to dashboard.us.enableiot.com

I read that the issue might be to do with my firewall or proxy, but i have no proxy and i don't think its an issue with firewall

Any ideas ?

7 Replies
Carlos_M_Intel
Employee
95 Views

Hi PeachyDinosaur,

What is the output of running the commands uname -a and systemctl status iotkit-agent?

How are you setting your network? Are you using conmman?

Are you able to ping to a website?

Please check that there aren't network issues in your configuration.

Regards,

Charlie

JFaul1
Novice
95 Views

Hi CMata_Intel,

I followed the same tutorial as PeachyDinosaur and ran into the exact same error.

I can can ping a website without any troubles. I'm connected to my wifi (no proxy) using connman (I followed this tuturial to do this: https://www.youtube.com/watch?v=4BDLbwUOlLE Enabling WiFi on an Intel® Galileo Board - YouTube).

uname -a output:

root@galileo:~# uname -a

Linux galileo 3.8.7-yocto-standard # 1 Tue Jun 9 22:07:14 GMT 2015 i586 GNU/Linux

 

and systemctl status iotkit-agent:

● iotkit-agent.service - iotkit-agent

Loaded: loaded (/lib/systemd/system/iotkit-agent.service; disabled)

Active: inactive (dead)

Jan 18 22:12:43 galileo systemd[1]: Stopped iotkit-agent

I would appreciate any help.

Regards,

Julia

Carlos_M_Intel
Employee
95 Views

Hi Julia,

Try updating your image, you can download the EGLIBC microSD card image from: https://software.intel.com/en-us/iot/hardware/galileo/downloads IoT - Intel® Galileo Board Download | Intel® Developer Zone.

After this, you should get after uname -a: Linux galileo 3.8.7-yocto-standard # 1 Tue Sep 29 22:16:33 GMT 2015 i586 GNU/Linux

While setting your network, use connman (you have to use your WiFi name and password):

root@galileo:~# connmanctl

connmanctl> enable wifi

connmanctl> scan wifi

connmanctl> exit

root@galileo:~# cat << EOF > /var/lib/connman/wifi.config

[service_wifi_b4b6765faaf0_4d7957694669_managed_psk]

Type = wifi

Security = wpa

Name = MyWiFi

Passphrase = MyPassPhrase

EOF

[From: http://www.malinov.com/Home/sergey-s-blog# LSB-compliant-Image Sergey's Blog - Malinov Family Web Presence [LSB Compliant Image Section]

If you still have problems run systemctl restart iotkit-agent

Regards,

Charlie

Carlos_M_Intel
Employee
95 Views

Hi Julia,

Do you have updates on this? Have you tried with the latest image version for Galileo?

Regards,

Charlie

JFaul1
Novice
95 Views

Hi Charlie,

Yes, I have tried with the latest image that gave me the expected result on uname -a and it seems to be working perfectly so far now.

Thank you.

Regards,

Julia

Carlos_M_Intel
Employee
95 Views

Hi PeachyDinosaur,

Have you been able to connect the board to the Intel Analytics Cloud?

Regards,

Charlie

idata
Community Manager
95 Views

Sorry for the the delayed response but my laptop decided to break and so I wasn't able to check the outputs of the commands you suggested. Yes I was able to ping sites using a WiFi connection and I used conmman to set it up.

Reply