Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
2,616 Views

JDK 64 bit on 32 bit machine (Windows 10)

Hi,

 

I am under Windows 10, 32 bit. I would like to install Eclipse as IDE to develop Intel Edison and I am following the tutorial here: https://software.intel.com/en-us/installing-the-eclipse-ide IoT - Installing the Eclipse* IDE | Intel® Developer Zone. You request to me to install a 64 bit version of JDK1.8. But it seems there is no way: if I try to install the 64 bit version of JDK, the OS blocks it.

 

Could you please give me suggestions?

 

 

Thank you!

 

7 Replies
Highlighted
28 Views

Yes, that definitely won't work. You can't install 64-bit SW on a 32-bit OS.

In general Windows 32-bit isn't supported. You may get it working however. There are threads on that topic somewhere in this forum as far as I recall

0 Kudos
Highlighted
Beginner
28 Views

Hi and thank you for help.

I agree with you but it is strange: I am following the guide to install Eclipse (IoT) for Windows 32 bit. The guide says:

https://software.intel.com/en-us/installing-the-eclipse-ide IoT - Installing the Eclipse* IDE | Intel® Developer Zone:

Java* SE Development Kit 8: Eclipse depends on a Java* Runtime Engine (JRE) to execute. You can run Eclipse with an earlier version of the JRE or Java Development Kit (JDK), but you must have the 64-bit version of Java SE Development Kit 8 (also called JDK version 1.8) to access the full range of Eclipse's capabilities. This includes the ability to create and run IoT projects in Java.

You can download the JDK fom Oracle at http://www.oracle.com/technetwork/java/javase/downloads/index.html http://www.oracle.com/technetwork/java/javase/downloads/index.html. Install the 64-bit JRE or JDK (indicated by x64 in the download name), not the 32-bit (x86) version.

EDIT: I can't find the thread. Could you link it please?

EDIT: I have just found

Highlighted
28 Views

A, sorry - seems I was wrong about the support for 32-bit Windows. Ok, then I'd assume it's a cut&paste error telling you to install the 64-bit JRE. I'd suggest you'd try with the 32-bit version? My 2 cents

0 Kudos
Highlighted
Employee
28 Views

Hi ago

Have you been able to install Eclipse in your machine?

Regards,

Charlie

0 Kudos
Highlighted
Beginner
28 Views

Hi I have the same problem, I can't find any help on how to get Eclipse working on a 32-bit machine ... doesn't seem possible - any help?

0 Kudos
Highlighted
Employee
28 Views

Hi Scott,

The IDE is intended to be used in a 64 bit configuration. You can try to install a 32bit JDK but you could have problems in the future.

Have you tried to force the installation of the JDK for 64 bit in your PC?

Regards,

Charlie

Highlighted
Beginner
28 Views

Hi Charlie,

Thanks for your response.

The 64-bit version would not install, I think I'll just have to get a virtual Linux machine running on my laptop.

Thanks,

Scott.

0 Kudos