Community
cancel
Showing results for 
Search instead for 
Did you mean: 
idata
Community Manager
1,463 Views

Joule no longer responding to keyboard and mouse

Jump to solution

My Joule 570 was happily responding to a keyboard and mouse plugged into a powered USB 3.0 hub. Now it will only accept input from the Host computer on a serial link. I must have messed up something in the BIOS editor accessed by pushing f2 upon boot up, but I don't know what that might be. When it does bood and I type "startxfce4" on the host computer, the external monitor does show the desktop but the mouse is frozen. have tried plugging the keyboard and mouse in after boot up, no joy. Have tried booting without the link to the host computer. No joy.

Ideas? Thanks

0 Kudos
1 Solution
idata
Community Manager
54 Views

tried plugging in the mouse and then the keyboard directly into the joule board. When each worked plugged in directly, I tried an old unpowered USB 2.0 hub which worked fine. Don't know why the brand new powered USB 3.0 hub seems to be on the fritz.

View solution in original post

4 Replies
idata
Community Manager
55 Views

tried plugging in the mouse and then the keyboard directly into the joule board. When each worked plugged in directly, I tried an old unpowered USB 2.0 hub which worked fine. Don't know why the brand new powered USB 3.0 hub seems to be on the fritz.

View solution in original post

idata
Community Manager
54 Views

Hi electricphred,

 

 

I'm glad to know that it is now working.

 

Have you checked if the USB 3.0 hub is still working? Does it respond if you connect it to your computer and connect different things to it? I'm wondering if the problem is with the Joule not recognizing it correctly or with the hub itself.

 

 

Regards,

 

-Pablo
idata
Community Manager
54 Views

Pablo:

It appears this brand new powered USB 3.0 hub bit the dust. Plugged it into a laptop and got "device not recognized". My confusion was because it had worked for a number of days with the Joule and probably 30 reboots. Sorry to waste bandwidth here. For others with similar woes, try plugging a mouse or keyboard directly into the Joule board.

idata
Community Manager
54 Views

Hi electricphred,

 

 

I'm sorry to hear that your hub is no longer working. And please don't hesitate to open a new thread if you have any question related to the Joule board. Thank you for your tip on plugging HIDs to the board.

 

 

Regards,

 

-Pablo
Reply