Showing results for 
Search instead for 
Did you mean: 

Joule proxy credentials required in an open network?

I have successfully connected Joule to an open network. I was able to Ping From my Win 10 host command line, I successfully pinged my Joule. I installed Intel System Studio for IoT (ISSI). Everything is fine up until I try to run a program from ISSI.

I get an error:

"Could not connect to target

Please check your proxy settings and ensure that your credentials are correct. If you are unsure you can clear your credentials in the context menu of the connection. "

This doesn't make sense to me, since the network is open. Wondering if anyone else has had this problem. I turned in a ticket in-house to see if my company IT guys have anything to add. But connecting to an open hot spot produces the same error.

What I am working with:

Host: Win 10, 64-bit, on an Intel x86

Open network

Linux Ostro Image that I retrieved last week (dated Aug 2016), booted from a USB stick. No SD card installed.

I have enabled SSH. I changed the password. I redid the entire thing with NO password, same result.

The Ostro mage has been decompressed and used the Win32 Disk Imager. I do not have another Joule to see if it will allow me to work with the original image that came on the Joule. It would not boot on the original image (not sure when/how that got corrupted) so I retrieved a new image and am getting these proxy credential requests on an open network. (Maybe I should try it on a secure network just to see what happens? Not looking forward to spending more time on this to perhaps get the same result...)


0 Kudos
2 Replies
Community Manager


The Joule boots into root by default (that's the only account present in the default image), the root account has no password by default, but SSH requires you to have a password. Can you make sure you have done this step after updating the OS -

I have it working now. I believe Win 10 was blocking the Eclipse platform.

I started over with a clean Windows 10 install (yes, really) and this time when the Windows firewall dialog box came up warning me about Eclipse, which says: "Windows firewall has blocked some features of eclipse on all public, private, and domain networks." Dialog box then asks " Allow eclipse to communicate on these networks: Domain networks, such as a workplace network Private networks, such as my home or work network Public networks, such as those in airports...".blah blah blah"

I checked all three and hit "Allow Access." I also updated the MRAA libraries, although I don't see how that would have affected my root access issue.

I have included a screen shot. Windows dialog box was blocking any operations such as starting Snip, so I literally took a screen shot with my phone. Note that this dialog box came up after the Intel IoT Target Connection "Create New SSH Target Connection" dialog box came up, as it is in the background.

Note that even when you RE-DO all of the steps from the beginning, once that firewall is set, it will NOT ask you again. I think this, and the fact that there was no error message (no password for Joule was correct), made me think for the longest time that it was an issue with how I had set up SSH with Joule. Even re-booting Joule with a new Linux image did not work, it still kept acting like I simply had the wrong password. Only wiping Win 10 and doing a fresh install fixed the problem. (I am not a Windows person and I didn't even think to check the Windows firewall.) This still does not make sense to me, but at least it's working now. I can't say that this was a brilliant idea to use a Windows host for a Linux target, but it was all I had at the time. Intel Joule User Guide does not have the same screen shots or instructions for Windows hosts, and clearly states that screen shots are of a Linux host install. Right around the user guide section titled "Setting up your host computer (Windows)" and "Running the IDE" instructions and screen shots start to diverge. The screen shots show options that are not available for Windows. For instance, it never populated a found connection for the Joule target for step 6. "Type your development platform's IP address in the Target name or IP address field. Click Next." I was able to muddle my way through it and hit a fatal error when the Windows Firewall dialog box came up and I had only checked one box (because I was on a public, open I checked that box. Made sense. Should have checked all 3.)

Anyway, that's what I found that worked for me. Finally. Don't reinstall Win 10, just open up the Firewall on Win 10 completely.

You might do better to do a complete defenestration of Windows and use a Linux host to begin with, but all my Linux machines are old laptops, and you need a modern PC for a host for Joule.