Intel® Makers
Intel® Edison, Intel® Joule™, Intel® Curie™, Intel® Galileo
Announcements
Welcome - This is a Peer-to-Peer Forum only. Intel has discontinued these products but you may find support from other customers on this Forum
9881 Discussions

MPU9250 Connection Failed

YLu12
Novice
1,331 Views

The IMU 10DOF is connected to the Intel Edison Arduino board.I use the code provided by Grove - IMU 10DOF Wiki. How to handle the problem "MPU9250 connection failed"?

The hardware connection is as the picture shows:

And the library is put into Arduino IDE:

The result is as follows:

In addition,the data did't update. Have you ever met this problems?

1 Solution
Diego_V_Intel
Employee
403 Views

Hello 朝露映曦,

I found another thread where you asked this same question. In fact, I answered you there explaining that the issue might be caused by the compatibility between the library and the Edison architecture:

Also, I suggested you a couple of alternatives that you might want to try in order to use the MPU-9250 and the BMP180. These alternatives were posted in your older thread. Please check it.

Regards,

Diego.

View solution in original post

1 Reply
Diego_V_Intel
Employee
404 Views

Hello 朝露映曦,

I found another thread where you asked this same question. In fact, I answered you there explaining that the issue might be caused by the compatibility between the library and the Edison architecture:

Also, I suggested you a couple of alternatives that you might want to try in order to use the MPU-9250 and the BMP180. These alternatives were posted in your older thread. Please check it.

Regards,

Diego.

Reply