Community
cancel
Showing results for 
Search instead for 
Did you mean: 
CHuan56
New Contributor I
1,097 Views

Missing Eclipse Repository

Jump to solution

Hello,

I am using an Intel Galileo2 with a customized image (details below). When attempting connect using the eclipse IDE I get the library issue "Could not detect repository version on the target". When using the Arduino IDE, the sample blink program successfully downloads, but the LED does not turn on. Looking further the directory /etc/opkg/ does not contain the files iotdk.conf or mraa-upm.conf.

 

Board: Intel Galileo Gen 2

Platform: 3.14.28-Yocto

BSP: 1.2.0 - latest from intel

Customization:

CONFIG_USB=y

CONFIG_USB_DEBUG=y

CONFIG_HIDRAW=y

CONFIG_HID_GENERIC=y

CONFIG_INTEL_QRK_GPIO_UIO=y

Is there a layer I am not including when I bitbaked?

Thanks in advance,

emanontogi

1 Solution
Thomas_L_Intel
Employee
137 Views

Hi emanontogi,

Eclipse IoT do not support custom environment so the message box "Could not detect repository version on the target" is intended.

The following workaround can enable the library synchronization but it is not guaranteed.

What is the content of your /etc/opkg.iotkit.conf?

Eclipse IoT expect to find inside this unique line:

src iotkit http://iotdk.intel.com/repos/2.0/intelgalactic http://iotdk.intel.com/repos/2.0/intelgalactic

Please note that technically, Eclipse IoT is using the following script for detecting the repository path (copy/paste for creating then running the script):

echo -e '# !/bin/bash\nREPO_PATH=`cat /etc/opkg/iotkit.conf 2> /dev/null`\nif [ -z "$REPO_PATH" ] || [[ ! "$REPO_PATH" =~ src\ iotkit\ .* ]]\nthen \nREPO_PATH=`cat /etc/opkg/mraa-upm.conf 2> /dev/null`\nif [ -z "$REPO_PATH" ] || [[ ! "$REPO_PATH" =~ src\ mraa-upm\ .* ]]\nthen\nREPO_PATH=""\nelse\nREPO_PATH =`echo $REPO_PATH | sed "s/src mraa-upm //"`\nfi\nelse\nREPO_PATH=`echo $REPO_PATH | sed "s/src iotkit //"`\nfi\necho $REPO_PATH' > /tmp/defaultRepo;

chmod 777 /tmp/defaultRepo;

/tmp/defaultRepo;

The expected output should be: http://iotdk.intel.com/repos/2.0/intelgalactic http://iotdk.intel.com/repos/2.0/intelgalactic

If the script works, you should not have this message box issue anymore.

Regards,

Thomas Lyet

View solution in original post

9 Replies
Carlos_M_Intel
Employee
137 Views

Hi emanontogi,

Using CONFIG_INTEL_QRK_GPIO_UIO=y could be affecting the performance of the GPIOS.

The UIO interface is non-coherent with the default gpiolib sysfs methods. The UIO

interface is not able to make atomic changes to the GPIO registers but the default

gpiolib sysfs methods are able to. Changes made by the default gpiolib sysfs

methods would be overwritten by the UIO interface in a race condition.

https://downloadmirror.intel.com/23197/eng/quark-x1000-linux-sw-developers-manual.pdf https://downloadmirror.intel.com/23197/eng/quark-x1000-linux-sw-developers-manual.pdf

Note also that the GPIO drivers cannot be built into the kernel if you wish to also

enable the UIO interface. This is due to the fact that the UIO driver is initialized after

the GPIO drivers and will result in a kernel panic on boot if allowed.

https://downloadmirror.intel.com/23197/eng/CLN_RelNotes.pdf https://downloadmirror.intel.com/23197/eng/CLN_RelNotes.pdf

Regarding Eclipse, which Eclipse version are you using?

Are you following the steps from https://software.intel.com/en-us/installing-the-eclipse-ide IoT - Installing the Eclipse* IDE | Intel® Developer Zone?

Regards,

Charlie

CHuan56
New Contributor I
137 Views

Hi Charlie,

CONFIG_INTEL_QRK_GPIO_UIO=y was added because the LEDs were not working on the first custom build (same configuration without GPIO_UIO). The version of Eclipse is Luna SR2 (4.4.2), and it works correctly with a non updated version of the image. Would you know what could possibly be causing the missing config files?

Regards,

emanontogi

CHuan56
New Contributor I
137 Views

Hi Charlie,

I rebuilt the image using BSP 1.0.1, and the repository seems to still be missing. This time the configuration was only

CONFIG_USB=y

CONFIG_USB_DEBUG=y

CONFIG_HIDRAW=y

CONFIG_HID_GENERIC=y

Any help would be much appreciated.

Thanks,

Emanontogi

Matthias_H_Intel
Employee
137 Views

sure you could do directly within Yocto. But: why not just create /etc/opkg/iotdk.conf?

CHuan56
New Contributor I
137 Views

Hi mhahn,

I created iotdk.conf and mraa-upm.conf, but the eclipse IDE still errors regarding a missing repository.

Thanks,

Carlos_M_Intel
Employee
137 Views

Hi emanontogi,

Could you post the error you are getting?

You can also install the packages with:

# opkg install http://iotdk.intel.com/repos/2.0/intelgalactic/upm_0.4.1_i586.ipk http://iotdk.intel.com/repos/2.0/intelgalactic/upm_0.4.1_i586.ipk

# opkg install http://iotdk.intel.com/repos/2.0/intelgalactic/mraa_0.8.1_i586.ipk http://iotdk.intel.com/repos/2.0/intelgalactic/mraa_0.8.1_i586.ipk

Do you have the headers in your PC? You can check this in C:\.......\Intel\iotdk-ide-win\devkit-x86\sysroots\i586-poky-linux\usr\include

Are you able to run another code, that doesn't use mraa or upm?

Regards,

Charlie

CHuan56
New Contributor I
137 Views

Thanks CMata,

It looks like this is the right step. I ran out of space because I forgot to increase IMAGE_ROOTFS_SIZE, but I'm looking into expanding the partition. I'll give an update once this is complete!

Regards,

emanontogi

Thomas_L_Intel
Employee
138 Views

Hi emanontogi,

Eclipse IoT do not support custom environment so the message box "Could not detect repository version on the target" is intended.

The following workaround can enable the library synchronization but it is not guaranteed.

What is the content of your /etc/opkg.iotkit.conf?

Eclipse IoT expect to find inside this unique line:

src iotkit http://iotdk.intel.com/repos/2.0/intelgalactic http://iotdk.intel.com/repos/2.0/intelgalactic

Please note that technically, Eclipse IoT is using the following script for detecting the repository path (copy/paste for creating then running the script):

echo -e '# !/bin/bash\nREPO_PATH=`cat /etc/opkg/iotkit.conf 2> /dev/null`\nif [ -z "$REPO_PATH" ] || [[ ! "$REPO_PATH" =~ src\ iotkit\ .* ]]\nthen \nREPO_PATH=`cat /etc/opkg/mraa-upm.conf 2> /dev/null`\nif [ -z "$REPO_PATH" ] || [[ ! "$REPO_PATH" =~ src\ mraa-upm\ .* ]]\nthen\nREPO_PATH=""\nelse\nREPO_PATH =`echo $REPO_PATH | sed "s/src mraa-upm //"`\nfi\nelse\nREPO_PATH=`echo $REPO_PATH | sed "s/src iotkit //"`\nfi\necho $REPO_PATH' > /tmp/defaultRepo;

chmod 777 /tmp/defaultRepo;

/tmp/defaultRepo;

The expected output should be: http://iotdk.intel.com/repos/2.0/intelgalactic http://iotdk.intel.com/repos/2.0/intelgalactic

If the script works, you should not have this message box issue anymore.

Regards,

Thomas Lyet

View solution in original post

CHuan56
New Contributor I
137 Views

Thank you!! This was definitely it! I also did a $opkg -list |grep iotkit to search for relevant packages to install.

Regards,

Reply