Community
cancel
Showing results for 
Search instead for 
Did you mean: 
idata
Community Manager
1,736 Views

NPM missing

I want to get some libraries for node, but my terminal says npm is not a command

please help. i am trying to work on another project and need NPM.

thks.

6 Replies
FTinetti
Honored Contributor I
21 Views

Hi JimmyIsTheBoss,

Take a look at

BR,

Fernando.

idata
Community Manager
21 Views

I keep getting iotdk.intel.com bad address

after running opkg update

idata
Community Manager
21 Views

i also get wget returned 1

idata
Community Manager
21 Views

Hello JimmyIsTheBoss,

 

 

Thanks for reaching out!

 

 

Could you please let us know the image you are using? You can verify this information with the command:

 

 

cat /etc/version

 

 

You should see the output 201605251601. In case you are receiving a different output, you will have to update to the latest image, which can downloaded from https://software.intel.com/en-us/iot/hardware/galileo/downloads. I suggest you to follow this guide: https://software.intel.com/en-us/get-started-galileo-windows-step1 in order to learn how to do it.

 

 

Once you are on the latest image, set an internet connection on your Galileo by either using an Ethernet cable or by setting wireless connectivity (learn how to do it in https://software.intel.com/en-us/get-started-galileo-windows-step4 or in http://www.malinov.com/Home/sergey-s-blog/intelgalileo-addingwifi) and then enter the following commands:

 

 

opkg update

 

opkg install nodejs-npm

 

 

When the commands finish running, you should be able to use npm.

 

 

Let me know how it goes.

 

-Peter.
idata
Community Manager
21 Views

i figured it out

first i added "src npm http://iotdk.intel.com/repos/3.5/iotdk/galileo/i586/" to /etc/opkg/iotdk.conf

then i ran opkg update

last i ran opkg install nodejs-npm

thanks

FTinetti
Honored Contributor I
21 Views

JimmyIsTheBoss wrote:

i figured it out

first i added "src npm http://iotdk.intel.com/repos/3.5/iotdk/galileo/i586/ http://iotdk.intel.com/repos/3.5/iotdk/galileo/i586/" to /etc/opkg/iotdk.conf

then i ran opkg update

last i ran opkg install nodejs-npm

thanks

That's documented in the link I posted above,

Fernando.