Community
cancel
Showing results for 
Search instead for 
Did you mean: 
JWils18
Beginner
1,845 Views

Network setup - IPv6 and DHCP client ID

Recently got my module, flashed the 201606061707 image and had a few setup hiccups.

1. How do I set the DHCP client ID for the edison? This would normally the hostname so my DHCP server will register a DNS record on my network so I can ssh to edison.lan instead of an IP address. On other systems (Windows, Mac, and linux) this Just Works, but not here.

2. How can I get IPv6 networking working? On my network IPv6 addresses are handed out automatically so normally I don't need to do anything, but the Edison only gets a v4 address. On my desktop Linux system this would be something to configure in /etc/network/interfaces but this file does not exist in the yocto system.

3. I found out the usb0 interface has a static address of 192.168.2.15/24. What happens if your local network actually uses 192.168.2.0/24? Then your Edison's networking will be completely broken since you have two conflicting routing tables. Any choice of address space is going to have this problem, so what's the point of the usb0 interface?

0 Kudos
8 Replies
JWils18
Beginner
86 Views

Solved the first problem with adding --hostname="$(hostname)" to udhcpc commands in /etc/wpa_supplicant/wpa_cli-actions.sh

Still struggling with IPv6. Other threads mentioned using connmanctl. It's not running by default and I found I needed to run "systemctl start connman" to use it. After I run that, then wlan0 loses its IPv4 address and gets a IPv6 address. Looks like it is getting autoconfigured IPv6 addresses, but it is no longer running udhcpc to get a IPv4 address, but I definitely want dual-stack networking.

idata
Community Manager
86 Views

Hello James,

 

 

Thank you for interest in the Intel® Edison Breakout Board.

 

 

In order to help you with your issue we'll need more time to do more research. As soon as I have more information I'll be contacting you.

 

 

Thank you for your patience.

 

 

Regards,

 

Andres

 

JWils18
Beginner
86 Views

I found a solution for connman that works in a WPA-PSK environment and gets dual-stacked connectivity. What I'm missing is how to set up WPA enterprise in connman - I'll see if there are other discussions related to that.

root@edison:~# systemctl start connman

root@edison:~# connmanctl

connmanctl> scan wifi

connmanctl> services

connmanctl> agent on

connmanctl> connect wifi___managed_psk

connmanctl> config wifi___managed_psk --ipv4 dhcp --ipv6 auto preferred

root@edison:~# systemctl enable connman

Copy Requires,After from wpa_supplicant.service to connman.service:

root@edison:/lib/systemd/system# diff -u connman.service~ connman.service

--- connman.service~

+++ connman.service

@@ -1,7 +1,7 @@

[Unit]

Description=Connection service

-Requires=dbus.socket

-After=dbus.socket connman-init.service

+Requires=dbus.socket sys-subsystem-net-devices-wlan0.device

+After=dbus.socket connman-init.service sys-subsystem-net-devices-wlan0.device

Before=remote-fs.target

idata
Community Manager
86 Views

Hello James,

 

 

We really appreciate that you are sharing your experience with the community, it helps us update your case and find a better solution to your issue.

 

 

As soon as I have relevant information I'll be contacting you through this community.

 

 

Thank you for your patience.

 

 

Regards,

 

Andres
idata
Community Manager
86 Views

Hello James,

 

 

I was wondering if you had any updates regarding your project.

 

 

Sorry for the late reply, but the research process took long than expected, I hope you understand.

 

 

When there is a conflict between usb0 and local network, it is possible to disable the usb0 device. This can be done using systemctl: systemctl disable network-gadget-init.service

 

 

If such conflict exists (between usb0 and local network) then it is possible to disable the usb0 device to avoid such conflict. Using systemctl: systemctl disable network-gadget-init.service. There have been a couple of threads that discuss this procedure:

 

https://communities.intel.com/thread/57302 https://communities.intel.com/thread/57302

 

https://communities.intel.com/thread/58222 https://communities.intel.com/thread/58222

 

 

Thank you for your patience.

 

 

Regards,

 

Andres
idata
Community Manager
86 Views

Hello James,

 

 

I was wondering if you had the chance to try to disable the usb0 device to avoid the conflict between usb0 and local network.

 

 

If you need further assistance, don't hesitate to contact us through this community.

 

 

Regards,

 

Andres

 

JWils18
Beginner
86 Views

Those is no such service file in the factory default image under the name "network-gadget-init.service". It's something that the author of that thread added to his own system.

The solution I settled on is to change or delete the "Address=" line in /etc/systemd/network/usb0.network, followed by reboot.

idata
Community Manager
86 Views

Hello jmw0,

 

 

Thank you for sharing your experience with the community, we really appreciate it.

 

 

Regards,

 

Andres