Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
930 Views

No Mount After failed flash, Is my board bricked? I think I've tried everything

I recently tried to flash my Edison board using the flashall script method on the mac for the newest Yocto image but after the reboot it timed out because it could no longer be detected/mounted. Strangely enough I can still get to the serial terminal. I think I have literally tried everything at this point and still can't get it to work I was hoping someone could point me in the right direction on some things I haven't tried or can figure out the issue.

 

USB

I tried 5 different cables and they all seemed to work meaning I can access the serial terminal through all of them. Definitely don't think this is the issue. I have also flipped the switch to the lowest position.

PowerSource

Using the wall plugin

Serial Terminal

When I login to root of the serial terminal I always get this error :

Poky (Yocto Project Reference Distro) 1.6 dewar ttyMFD2

Dewar login: root

[ 786.294431] systemd-fsck[7798]: fsck.ext2: Bad magic number in super-block while trying to open /dev/mmcblk0p10

[ 786.296969] systemd-fsck[7798]: /dev/mmcblk0p10:

[ 786.298982] systemd-fsck[7798]: The superblock could not be read or does not describe a correct ext2

[ 786.301585] systemd-fsck[7798]: filesystem. If the device is valid and it really contains an ext2

[ 786.304409] systemd-fsck[7798]: filesystem (and not swap or ufs or something else), then the superblock

[ 786.307226] systemd-fsck[7798]: is corrupt, and you might try running e2fsck with an alternate superblock:

[ 786.310168] systemd-fsck[7798]: e2fsck -b 8193

No directory, logging in with HOME=/

Tried this method:

boot > run do_ota

** Unrecognized filesystem type **

Saving Environment to MMC...

Writing to redundant MMC(0)... done

.VVBD.0000000c

microkernel built 11:24:08 Feb 5 2015

******* PSH loader *******

Also tried

boot > run do_flash

Saving Environment to MMC...

Writing to MMC(0)... done

GADGET DRIVER: usb_dnl_dfu

**freezes here

from the do_flash I tried these below in conjunction

Flashall.sh << cannot detect fails and times out

Flashall.sh --recovery << Tried this on my linux comp and get 20x Intel SoC Detection Failed : Attempt up to 20 times

Flash tool lite << cannot detect fails and times out

I just don't get it because if I can login to the root serial terminal shouldn't I be able to flash the image??? I've tried this on Windows 7, Linux 32bit-Ubuntu 14.04 and Mac OSX 10, is my board broken?

6 Replies
Highlighted
Beginner
12 Views

Hi dewar,

I guess this happened to me as well. I just bought a Arduino one one week ago and tried very hard to flash it, but failed, the same problem as you met with, cannot detect and times out. I also tried the flash tool lite and the manual way with Win7 and mac, but neither was working.

host22-114:edison-image-ww25.5-15 kilter$ ./flashall.sh

Using U-Boot target: edison-blankcdc

Now waiting for dfu device 8087:0a99

Please plug and reboot the board

Flashing IFWI

Download [=========================] 100% 4194304 bytes

Download [=========================] 100% 4194304 bytes

Flashing U-Boot

Download [=========================] 100% 237568 bytes

Flashing U-Boot Environment

Download [=========================] 100% 65536 bytes

Flashing U-Boot Environment Backup

Download [=========================] 100% 65536 bytes

Rebooting to apply partition changes

Now waiting for dfu device 8087:0a99

Timed out while waiting for dfu device 8087:0a99

DEBUG: lsusb

DEBUG: dfu-util -l

dfu-util 0.8

Copyright 2005-2009 Weston Schmidt, Harald Welte and OpenMoko Inc.

Copyright 2010-2014 Tormod Volden and Stefan Schmidt

This program is Free Software and has ABSOLUTELY NO WARRANTY

Please report bugs to mailto:dfu-util@lists.gnumonks.org dfu-util@lists.gnumonks.org

Deducing device DFU version from functional descriptor length

Found Runtime: [05ac:821a] ver=0042, devnum=7, cfg=1, intf=3, alt=0, name="UNKNOWN", serial="UNKNOWN"

host22-114:edison-image-ww25.5-15 kilter$

I doubt whether this is a hardware problem or not?

0 Kudos
Highlighted
Beginner
12 Views

Were you able to fix the problem??

Are you able to reflash your board each time and have it time out or does it no longer detect the board at all?

0 Kudos
Highlighted
Beginner
12 Views

Nope, I'm still working on this problem.

Sometimes it stopped at "Please plug and reboot the board"

Sometimes I got chance to go through this and got some flashing print. Howerver it will stop at the second wait for sure.

I'm confused "Rebooting to apply partition changes" means it will reboot automatically, or I should do it?

Also, I can not access to the serial port. I guess flashing the board is neccessary before you use the serial port. Without a serial port, I cannot make a soft reboot.

Lots of such problems in this forum, but have no time go through all of them.

0 Kudos
Highlighted
Employee
12 Views

Hi kilter and dewar,

There are two recommended methods to flash the Edison, the flashall and the Flash Tool Lite. You can see steps to do each here:

https://software.intel.com/en-us/articles/flash-tool-lite-user-manual IoT - Flash Tool Lite User Manual | Intel® Developer Zone

In case none of these work another user found an alternative solution described here .

Let me know if one of these three methods work.

Sergio

0 Kudos
Highlighted
Employee
12 Views

Do you still have problems trying to flash your Edison board? Have you tried the methods recommended in the previous reply?

Sergio

0 Kudos
Highlighted
Beginner
12 Views

Yes, I tried the manual methods, but it failed. Luckily, I tried the flash tool lite on Surface pro(WIN 10), and it succeeded.

You know what, I cannot say Edison is a stable product. I tried three times with the same condition, and it succeeded only at the third time. No idea why.

BTW, Edison can work well with USB 3.0 in conflict with previous words in this forum. That's very weird.

0 Kudos