Community
cancel
Showing results for 
Search instead for 
Did you mean: 
idata
Community Manager
1,819 Views

No java on Edison

Jump to solution

I am having trouble with an Edison that does not seem to have java installed, I get the error opkg_install_cmd: Cannot install package openjdk-8-java when I try to install it or the eclipse editor trie to install it. when I try to run a java script i get

Java is not installed on your target.

Your project can't run on this target

0 Kudos
1 Solution
idata
Community Manager
45 Views

Hello ShakerBreaker,

Thank you for your interest in Intel® Edison Breakout Board.

I understand you are having trouble running Java in your Edison board.

Could you please tell me if you are using Intel® System Studio IoT Edition to develop your project? If that is the case, have you followed the official user guide? Link: https://software.intel.com/en-us/intel-system-studio-iot-edition-guide-for-java https://software.intel.com/en-us/intel-system-studio-iot-edition-guide-for-java. Also, make sure you are using the latest version: https://software.intel.com/en-us/iot/tools-ide/ide/iss-iot-edition https://software.intel.com/en-us/iot/tools-ide/ide/iss-iot-edition.

The board should run Java by default, so I recommend you to manually flash the firmware by following this guide: https://software.intel.com/en-us/flashing-the-firmware-on-intel-edison-board https://software.intel.com/en-us/flashing-the-firmware-on-intel-edison-board.

Please let me know how this turns outs.

I'll be waiting for your response.

Have a nice day.

Regards,

 

Andres V.

View solution in original post

10 Replies
idata
Community Manager
46 Views

Hello ShakerBreaker,

Thank you for your interest in Intel® Edison Breakout Board.

I understand you are having trouble running Java in your Edison board.

Could you please tell me if you are using Intel® System Studio IoT Edition to develop your project? If that is the case, have you followed the official user guide? Link: https://software.intel.com/en-us/intel-system-studio-iot-edition-guide-for-java https://software.intel.com/en-us/intel-system-studio-iot-edition-guide-for-java. Also, make sure you are using the latest version: https://software.intel.com/en-us/iot/tools-ide/ide/iss-iot-edition https://software.intel.com/en-us/iot/tools-ide/ide/iss-iot-edition.

The board should run Java by default, so I recommend you to manually flash the firmware by following this guide: https://software.intel.com/en-us/flashing-the-firmware-on-intel-edison-board https://software.intel.com/en-us/flashing-the-firmware-on-intel-edison-board.

Please let me know how this turns outs.

I'll be waiting for your response.

Have a nice day.

Regards,

 

Andres V.

View solution in original post

idata
Community Manager
45 Views

I am having trouble running java, not java script, it seems it was not in the yocto package

idata
Community Manager
45 Views

I have already tried to flash the chip, it did not seem to fix the issue, i have 3 other edisons on my desk, none have this problem

idata
Community Manager
45 Views

Hello ShakeBreaker,

 

 

Thanks for the information provided.

 

 

Could you please tell me if you flashed all your boards following the same method (manual flashing) and if you have the same version in all of them?

 

 

If that is the case, then you may have one defective unit, and you may have to undergo a replacement process.

 

 

I'll be waiting for your response.

 

 

Regards,

 

Andres V.
idata
Community Manager
45 Views

Hey Andres,

Got a new Edison, straight from the box, ran through the setup tool, flashed it to latest, says it was updated with weekly-159, set up password, wifi, ssh'd in .. no Java

idata
Community Manager
45 Views

Hello ShakerBreaker,

 

 

Thank you for the information provided.

 

 

Could you please open a PuTTY terminal and run the following command? Please tell me what is the output.

 

 

cat /etc/version

 

 

I'll be waiting for your response.

 

 

Regards,

 

Andres V.
idata
Community Manager
45 Views
idata
Community Manager
45 Views

cat /etc/issue reults in

Poky (Yocto Project Reference Distro) 1.7.2 \n \l

idata
Community Manager
45 Views

Hey Andres,

I went through the manual flash again, got the same complete messages as the first time, but for whatever reason, java is now there and the version is 201606081705 .. could this have been an issue with a new mac with the new os?

idata
Community Manager
45 Views

Hello ShakerBreaker,

 

 

I'm glad to hear that you could solve the issue.

 

 

I think the issue might be related to the flashing method, sometimes the setup tool doesn't flash the latest version, and the manual method provides better results.

 

 

Have a nice day.

 

 

Regards,

 

Andres V.
Reply