Intel® Makers
Intel® Edison, Intel® Joule™, Intel® Curie™, Intel® Galileo
Welcome - This is a Peer-to-Peer Forum only. Intel has discontinued these products but you may find support from other customers on this Forum
9872 Discussions

No response when connected by serial to Edison for the first time


I have followed the setup instructions for a new Edison kit for Arduino. I am installing from 64 bit Ubuntu. When I try to establish a serial communication, i get no response, just a flashing cursor.


I have flashed Yocto 3.0 onto the board 3 different times, once using the Flash Tool and twice using the command line It appears to work fine, no errors, files download and install, and the board reboots but when ever I connect to the board, I get no response.


I have hit enter many times. I also have tried and type 'root' and enter and enter in case I just can not see the prompt.



I connect using screen with the following command 'sudo screen /dev/ttyACM0 115200'. I have also tried minicom using the command 'sudo minicom -D /dev/ttyACM0 -b 115200'. In both cases, I connect but get no response. When I plug in the USB, the computer brings up the board as removable media, an empty drive with 803.7 MB free.

In minicom, I have tried terminal mode of both ANSI and VT102 but nothing changes.

Any help would be appreciated.

0 Kudos
2 Replies
Community Manager

Hi randy16,



I think the problem is the dev you are using, you should use ttyUSB0 instead of ttyACM0, the ttyACM0 is not the FTDI port for Linux console, it is for using it with the Arduino IDE.


Try with: sudo screen /dev/ttyUSB0 115200








Thank you! For clarification (and maybe it will help other newbs) I did not have the correct USB plugged in. Plugging in the middle USB gives power and allows you to flash the board but it connects as ACM0, not as USB0. You need to connect the USB closest to the edge of the board to get a FTDI port. The command 'lsusb' will tell you if you have a USB-serial (UART) USB connection.

Thanks again.