Community
cancel
Showing results for 
Search instead for 
Did you mean: 
AAsar
Beginner
1,110 Views

Problem Setting up Amazon Web Services IoT Device SDK on the Intel Edison Board

Hi, i've been trying to set up the aws IoT sdk on my edison board.

I'm following these instructions: https://software.intel.com/en-us/articles/setup-aws-iot-intel-edison-board Setting up Amazon Web Services (AWS)* IoT Device SDK on the Intel® Edison™ Board | Intel® Software

I've mostly succeeded.

The issue is with the last step.

While i'm trying to publish a topic, i get an error message saying: "Problem setting TLS options"

After reading up on a few forums, one of the reasons why this was happening was, I believe, the version of MQTT. Thus, i upgraded to version 1.4.4 by following the instructions in the correct answer posted by lbabaly in this forum:

Inspite of this, I am still getting the same error.

Could you please familiarize me with the meaning of this error and how to go about resolving it.

I am new to AWS and IoT.

Tags (1)
0 Kudos
1 Reply
idata
Community Manager
25 Views

Hi me_5,

Thanks for your interest in the Intel® Edison™ Platform.

Unfortunately, Amazon Web Services is out of the scope of our support. I would encourage you to contact the Amazon Forums (https://forums.aws.amazon.com/index.jspa https://forums.aws.amazon.com/index.jspa ), they might be able to help you further.

Now, I have done my own investigation and I found this guide that might be useful to you: https://seeeddoc.github.io/Intel-Edison_and_Grove_IoT_Starter_Kit_Powered_by_AWS/ Intel® Edison and Grove IoT Starter Kit Powered by AWS .

Hope this helps, have a nice day!

Best Regards,

 

-Jose P.
Reply