Intel® Makers
Intel® Edison, Intel® Joule™, Intel® Curie™, Intel® Galileo
Announcements
Welcome - This is a Peer-to-Peer Forum only. Intel has discontinued these products but you may find support from other customers on this Forum
9872 Discussions

Problem connect to WPA2 ENT Network for my Intel Edison

ttneh
Novice
1,504 Views

my Edison is unable to connect to the WPA2 enterprise network. is it got any setting or step need to done before connect? like, insert the WPA cert into intel Edison? if yes then what is the way?

1 Solution
idata
Community Manager
200 Views

Hi,

 

 

How are you attempting to connect to this network? There's some additional configuration required. You need to have the certificates inside the network configuration so they're recognized and you'll be able to connect. The certificates should be placed in the /etc/wpa_supplicant/wpa_supplicant.conf.

 

 

This is an example of how the wpa_supplicant.conf file should look like

 

network={

 

ssid="WPI-Wireless"

 

key_mgmt=WPA-EAP

 

proto=WPA2

 

pairwise=CCMP

 

group=CCMP

 

eap=TLS

 

 

identity="[YOUR_WPI_EMAIL]@wpi.edu"

 

 

ca_cert="/home/pi/certs/CA-[A_BUNCH_OF_NUMBERS].pem"

 

client_cert="/home/pi/certs/certificate.pem"

 

private_key="/home/pi/certs/certificate.p12"

 

private_key_passwd="[YOUR_WPI_EMAIL_PASSWORD]"

 

 

priority=1

 

}

 

 

You can see more information here /message/343704# 343704 https://communities.intel.com/message/343704# 343704

 

 

-Sergio

 

View solution in original post

4 Replies
idata
Community Manager
201 Views

Hi,

 

 

How are you attempting to connect to this network? There's some additional configuration required. You need to have the certificates inside the network configuration so they're recognized and you'll be able to connect. The certificates should be placed in the /etc/wpa_supplicant/wpa_supplicant.conf.

 

 

This is an example of how the wpa_supplicant.conf file should look like

 

network={

 

ssid="WPI-Wireless"

 

key_mgmt=WPA-EAP

 

proto=WPA2

 

pairwise=CCMP

 

group=CCMP

 

eap=TLS

 

 

identity="[YOUR_WPI_EMAIL]@wpi.edu"

 

 

ca_cert="/home/pi/certs/CA-[A_BUNCH_OF_NUMBERS].pem"

 

client_cert="/home/pi/certs/certificate.pem"

 

private_key="/home/pi/certs/certificate.p12"

 

private_key_passwd="[YOUR_WPI_EMAIL_PASSWORD]"

 

 

priority=1

 

}

 

 

You can see more information here /message/343704# 343704 https://communities.intel.com/message/343704# 343704

 

 

-Sergio

 

ttneh
Novice
200 Views

I tried the method above but it still cant, it shows

Attempting to enable network access, please check 'wpa_cli status' after a minute to confirm.

not connected.something went wrong

warning: SSH is not yet enabled on the wireless interface. To enable SSH access to this device via wireless run configure_edison --password first.

idata
Community Manager
200 Views

Could you provide the full output of wpa_cli status? Have you already configured SSH as pointed in the warning massage? Enable SSH and let us know your results.

 

 

We'll be waiting for your response.

 

 

-Sergio
ttneh
Novice
200 Views

thanks Sergio,

after I delete all the data in /etc/wpa_supplicant/wpa_supplicant.conf and retype the code that you give me , its work!!!

Reply