Community
cancel
Showing results for 
Search instead for 
Did you mean: 
JHrib
New Contributor II
1,360 Views

Problem fixing a bricked Galileo Gen2 using Galiprog

Hello, everyone.

I am trying to fix my Galileo board gen 2 using https://github.com/xbolshe/galiprog Galiprog. I am using Galiprog because conventional method of restoring Galileo using USB stick with FVMAIN.fv file and putting Galileo in Force recovery mode failed. I don't have JTAG programmer. I followed instructions posted in the GitHub repository. The only difference is I was using two Galileos gen 2 as oppose to the instructions where Galileos are of different generations. On the board, I loaded a file saved in the repository. I renamed it from "Flash-missingPDAT_Release-1.0.4.bin" to "galiprog_flash_write.bin". I successfully loaded the file on the board and also verified the flash as instructions specified.

When I power on the board I get the following screen:

If I press 5 or any other key except for "enter", the board freezes and nothing happens. I waited for three hours to see if anything happens, I put the board in Force recovery, and I loaded the file again. Unfortunately, I had no success. Does anyone know what else I could do? Instructions for the Galiprog end after the flash is loaded with ".bin" file.

Please find attached flash dump file, before I reflash the board and the file I loaded onto flash.

Kind regards

Jernej

0 Kudos
3 Replies
idata
Community Manager
39 Views

Hi Jernej,

 

 

Thanks for your interest in the Intel® Galileo Platform.

I'm sorry to hear that your Galileo is still bricked after using the Galiprog method. If you check the documentation of the Galiprog, you will see that using two Galileo Gen 2 hasn't been tested, this might be the reason why this method isn't working. I would suggest to try to acquire a Galileo Gen 1 in order to try again the Galiprog method.

Also here is another method that might be worth the shot: .

Please let me know your results, have a nice day!

Best Regards,

 

-Jose P.
JHrib
New Contributor II
39 Views

Hi, Jose.

I tried the approach you suggested. Unfortunately, my board does not get to the shell. Is there any other file I should use to flash the board? I noticed that the flash file is the same as when flashing with Galiprog or using UEFI internal shell.

Kind regards

Jernej

idata
Community Manager
39 Views

Hi Jernej,

 

 

If none of the recovery guides have worked for you, could you be so kind to open a ticket in this link https://supporttickets.intel.com/?lang=en-US https://supporttickets.intel.com/?lang=en-US stating that you already follow all the recovery guides (Please attach the link of this thread). Then we will be happy to start the process of a replacement if you meet the necessary requirements.

Please let me know if any questions come up, have a nice day!

Best Regards,

 

-Jose P.
Reply