Community
cancel
Showing results for 
Search instead for 
Did you mean: 
idata
Community Manager
1,181 Views

Problems Connecting 4G Modem

I have been trying to connect a Multitech LAT1U usb modem to intel edison. I had problems edison identifying modem. Finally I found a solution that is add serial drivers such as option, qmi_wwan, usbserial.

To include option driver, I have re-compiled the firmware.

Now I am able to recognize usb_modem but as a storage device. After going through posts, I have found that using usb_modeswitch I will not have such a problem. But in order to include , when I add IMAGE_INSTALL_append += "usb-modeswitch" to recipe file. I get an error Nothing provides "usb-modeswitch" .

Any help would be appreciated.

Message was edited by: Siva Aduri

Tags (1)
0 Kudos
4 Replies
idata
Community Manager
53 Views

Hi Siva,

 

 

Thank you for contacting us.

 

Regarding your project, I haven't done anything similar before, however I have found some other threads in a different Community that might be of help.

 

http://stackoverflow.com/questions/30861995/error-while-adding-meta-oic-layer-to-an-intel-edison-ima... http://stackoverflow.com/questions/30861995/error-while-adding-meta-oic-layer-to-an-intel-edison-ima....

 

Let us know if helps you.

 

 

Regards,

 

-Pablo
idata
Community Manager
53 Views

Hi Pablo,

Thank you for the reply.

I have tried the suggestions in link you have shared, sadly It did not work.

Thanks,

Siva

idata
Community Manager
53 Views

Hi Siva,

 

 

Could you please provide the whole log of the error? I would like to know if there's some more information related to the usb-modeswitch error you're getting, maybe some information on its dependencies.

 

 

Regards,

 

-Pablo
idata
Community Manager
53 Views

Hi Siva,

 

 

Last time we requested the whole log of the error you were getting. Are you still having issues with this?

 

 

Regards,

 

-Pablo
Reply